cancel
Showing results for 
Search instead for 
Did you mean: 

IE 11 Compatibility Mode issues

IE 11 Compatibility Mode issues

I have Magento 2.2.0 Open Source and I have found that I am having issues with Internet Explorer 11 when Compatibility Mode is active. When Compatibility Mode if off, or when using any other browser, the site renders fine.  I have attached an image of how the page renders when it is on.

 

I have added the following code into the head, but it doesn't seem to correct the problem:

<meta http-equiv="X-UA-Compatible" content="IE=edge">

 

Does anyone have any suggestions?screen-shot.jpg

3 REPLIES

Re: IE 11 Compatibility Mode issues

Magento 2 only supports IE 11 and later, so it may/will not work in compatibility mode which is simulating older browser versions. 

 

See http://devdocs.magento.com/guides/v2.0/install-gde/system-requirements_browsers.html

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: IE 11 Compatibility Mode issues

Is this a change with 2.2?  We also have a 2.1.9 Open Source site running and we don't get this problem when it is opened in Compatibility Mode.

Re: IE 11 Compatibility Mode issues

The page I linked to was for 2.0.x branch so it looks like older than IE 11 has never been supported in this branch. 

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!