cancel
Showing results for 
Search instead for 
Did you mean: 

Image cache not generated after product import.

Image cache not generated after product import.

I'm setting up a new store in Magento 2.0.2 and looking to use the import feature to upload ~2500 SKUs. I've dropped all product images into pub/media/import and referenced the location for each SKU during import so that everything is nicely linked.

 

The import is successful and after a reindex the items are visible in the store. However one issue appears to affect all of them. 

 

Whilst frontend product pages correctly display the base images, only a placeholder magento graphic is displayed for thumbnails. This is true both for product grids on the frontend and the product list in the admin. Selecting an item from the admin product list allows me to see that a base image is present and set, but either no preview has been generated or none is being displayed. 

 

Looking into the product cache folder it appears that only one SKU (the first on the import list) has had thumbnails generated for it. This thumbnail is still not displayed for the product. 

 

I've tried reindexing, flushing pregenerated product images files and the magento cache as a whole. I've also gone through and deleted all items to start the upload process again but the behavior remains the same. 

If I add a new product manually and upload an image for it, the thumbnail generates and the product is displayed correctly.

If I take an existing product uploaded through the import feature, remove any product images and save, and then return and upload a new image, the preview image still does not update and the product continues to display the placeholder. 

5 REPLIES

Re: Image cache not generated after product import.

May be you have "dropped all product images" with inappropriate filesystem permissions?

Re: Image cache not generated after product import.

I'm not sure what you mean by that, but I'd put that down to being fairly new to this. I've had some issues with directory permissions since a recent backup restoration. Perhaps its related to that? I got around this issue for now by placing the same import reference in the columns for thumbnail and preview images. It doesn't feel like the right thing to do but its worked. 

Re: Image cache not generated after product import.

Magento 2 requires the following filesystem permissions: http://devdocs.magento.com/guides/v2.0/install-gde/prereq/file-system-perms.html

Re: Image cache not generated after product import.

I've the same problem with the Magento 2.0.7

 

Possible solutions tried:

  • Permissions verified
  • cache disabled
  • cache flushed
  • cache removed from SSH
  • bin/magento indexer:reindex

 

Somebody got any solution?

Re: Image cache not generated after product import.

during my research I'm find out something weird. The grid layout take the pictures from a folder called "small_image" inside of "pub/media/catalog/product/cache/x/" but when I add a new image to a product Magento add this image to folder "pub/media/catalog/product/cache/5/thumbnail/110x110/xxxxxxxxxxxx/x/x/" thats is why the gris layout don't find the image and is replaced by the placeholder image....