cancel
Showing results for 
Search instead for 
Did you mean: 

Index Stuck "Processing"

Index Stuck "Processing"

I have 2 indexes that always stay in "Processing".

Specs:

Magento CE 2.1.7

php 7.0.21

mysql 5.6.35

 

I have tried indexer:reset, and indexer:reindex on both and I get this error:

Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors for more info on how to handle out of memory errors.root@server.xxxxx.com [xxxxx]#

I have set these to all kinds of values and none work. I have tried the memory limit up to the full 4G, and I have even set them to unlimited and it still errors out:

 

max_execution_time = 0
max_input_time = 0
memory_limit = -1

 

php bin/magento indexer:status
Design Config Grid:                            Ready
Customer Grid:                                 Ready
Category Products:                             Ready
Product Categories:                            Ready
Product Price:                                 Ready
Product EAV:                                   Ready
Stock:                                         Ready
Catalog Rule Product:                          Processing
Catalog Product Rule:                          Processing
Catalog Search:                                Ready

 

I am not able to create new products due to this..

Any help would be appreciated. Thanks in advance...

 

 

3 REPLIES

Re: Index Stuck "Processing"

Bump..

Re: Index Stuck "Processing"

Stuck at the same issue, hope some one can help.

Tried memory_limit = -1 on all the levels, but nothing Smiley Indifferent

Re: Index Stuck "Processing"

Solved it !

@cci1if you are on a shared host, you have to change the root php.ini

Type in your shell :

php -r "echo ini_get('memory_limit').PHP_EOL;"

to see if it changes.

and php -- ini to find where you should change it.

Hope it helps.