cancel
Showing results for 
Search instead for 
Did you mean: 

Indexer stuck in processing

Indexer stuck in processing

Magento ver. 2.0.7

Hello, I'm trying to reindex my store so that products I added from the backend will show up on the frontend.

As shown below, after running

bin/magento indexer:reindex

every index has been rebuilt successfully but

bin/magento indexer:status

 shows some of the indices still processing as confirmed in the Admin Panel > System > Index Management

 

[user@server root]$ bin/magento indexer:reindex
Customer Grid index has been rebuilt successfully in 00:00:00
Category Products index has been rebuilt successfully in 00:00:00
Product Categories index has been rebuilt successfully in 00:00:00
Product Price index has been rebuilt successfully in 00:00:04
Product EAV index has been rebuilt successfully in 00:00:06
Stock index has been rebuilt successfully in 00:00:00
Catalog Rule Product index has been rebuilt successfully in 00:00:00
Catalog Product Rule index has been rebuilt successfully in 00:00:00
Catalog Search index has been rebuilt successfully in 00:00:00

[user@server root]$ bin/magento indexer:status
Customer Grid:                                     Processing
Category Products:                                 Processing
Product Categories:                                Processing
Product Price:                                     Ready
Product EAV:                                       Ready
Stock:                                             Ready
Catalog Rule Product:                              Ready
Catalog Product Rule:                              Ready
Catalog Search:                                    Processing

 

What can I do to resolve this? My website no longer shows any products.

 

Index Management.png

1 REPLY

Re: Indexer stuck in processing

unfortunately your only option is to set change in the database the state of the processing indexes because till there are processing indexes no other index gets updated and neither the command line works.

 also keep in mind this bug https://github.com/magento/magento2/issues/5146 that might be the cause for your problem

update indexer_state set status = 'invalid' where indexer_id = 'catalogsearch_fulltext';