cancel
Showing results for 
Search instead for 
Did you mean: 

M2.2.1 Order details bug

SOLVED

M2.2.1 Order details bug

Hi,


I've got a M2.2.1 store and when I get an order, I cannot see the details in the backed.
Each time I click on an order to see the details, I get the following error message :

 

[ERROR]

Fatal error: Uncaught TypeError: Argument 2 passed to Magento\Framework\View\Element\UiComponentFactory::argumentsResolver() must be of the type array, null given, called in C:\wamp64\www\magento2\vendor\magento\framework\View\Element\UiComponentFactory.php on line 198 and defined in C:\wamp64\www\magento2\vendor\magento\framework\View\Element\UiComponentFactory.php:164 Stack trace: #0 C:\wamp64\www\magento2\vendor\magento\framework\View\Element\UiComponentFactory.php(198): Magento\Framework\View\Element\UiComponentFactory->argumentsResolver('sales_order_vie...', NULL) #1 C:\wamp64\www\magento2\vendor\magento\framework\View\Layout\Generator\UiComponent.php(135): Magento\Framework\View\Element\UiComponentFactory->create('sales_order_vie...', NULL, Array) #2 C:\wamp64\www\magento2\vendor\magento\framework\View\Layout\Generator\UiComponent.php(97): Magento\Framework\View\Layout\Generator\UiComponent->generateComponent(Object(Magento\Framework\View\Layout\Data\Structure), 'sales_order_vie...', Array, Object(Magento\Framework\ in C:\wamp64\www\magento2\vendor\magento\framework\View\Element\UiComponentFactory.php on line 164

[/ERROR]

 

Can anybody help me?

 

Best regards,

7 REPLIES

Re: M2.2.1 Order details bug

Hi @webagrippa

 

you have issue of Factory classes/Method.

 

to resolve the issue kindly follow the below steps :

 

  1.  rm -rf  var/generation
  2. rm -rf generated
  3. rm -rf var/cache
  4. rm -rf var/page_cache
  5. php bin/magento setup:di:compile
  6. php bin/magento setup:static-content:deploy -f
  7. php bin/magento cache:clean
  8. php bin/magento cache:flush

 

Then check , It will works !!

if issue solved,Click Kudos & Accept as Solution

Re: M2.2.1 Order details bug

Hi ManthanDave,


Thanks for your quick reply.

I tried your solution, but it did not change anything at all. I still have the same error message.

Do you have any other idea?

 

Best regards,

Re: M2.2.1 Order details bug

Hi @webagrippa

 

okay i understand - so could you please confirm , you have any custom module in your magento 2 directory or you have custom theme for the same ? 

 

Sometimes when this does not work you should check all classes passed as an arguments to the __construct method, seems some of it is incorrect.

if issue solved,Click Kudos & Accept as Solution

Re: M2.2.1 Order details bug

Thanks again for your help. I'm sorry, but I'm not an expert, so I do not know what do you mean with

 

"Sometimes when this does not work you should check all classes passed as an arguments to the __construct method, seems some of it is incorrect."

 

I'm using LUMA standard Theme.

 

The extra modules I've installed are :

Lyranet

* Lyranetwork_Sogecommerce

 

Weltpixel

*WeltPixel_Backend

* WeltPixel_GoogleCards

* WeltPixel_LazyLoading

* WeltPixel_OwlCarouselSlider

*WeltPixel_Quickview

 

Owebia :

*Owebia_AdvancedShippingSetting

* Owebia_AdvancedSettingCore

 

Vnecoms

*Vnecoms_DeleteOrders

 

Mageplaza

* Mageplaza_Core 

* Mageplaza_Smtp

 

Magecomp

* Magecomp_Deleteorder

 

Magehost

* MageHost_PerformanceDashboard

* Magento_AdminNotification

 

Does this help you to find out the problem?

Re: M2.2.1 Order details bug

Hi @webagrippa

 

okay i understand !!! so as mention by you, you have multiple custom module installed.

 

so might be one of module have issue with your setup , so do one thing kindly disabled your module one by one and check that it is working or not.

 

you can disable module by two ways :

 

Either running command - php bin/magento setup:module:disable VendorName_Module

 

Second thing edit your config.php find those module do 1 to 0 its value

 

then run setup:upgrade command and check.

 

once you find the issue which module is conflicting then keep that module as disable and enable all other modules.

 

 

It will works !!

if issue solved,Click Kudos & Accept as Solution

Re: M2.2.1 Order details bug

Unfortunately, I did not succeed to find out which module generated the bug. Thus, I made a brand new installation of M 2.2.3 and everything is ok now.

Thanks for your help.

Best regards,

Re: M2.2.1 Order details bug

Hi @webagrippa

 

Glad to know that you have resolved your issue !!

 

happy to help and keep helping Smiley Happy

 

if issue solved,Click Kudos & Accept as Solution