cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.3.4 Undefined index: decimal(12,4) NOT NULL default 0

Highlighted

Magento 2.3.4 Undefined index: decimal(12,4) NOT NULL default 0

I am trying to install a Reward Point Extension from MagePlaza, after i upload the files and enable the module via SSH, My site crashes.

 

After the extension install I run bin/magento setup:upgrade and get this message:

 

Undefined index: decimal(12,4) NOT NULL default 0 in/vendor/magento/framework/Setup/SchemaListener.php on line 137

I get this error message on my site:

 

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory.
The following modules are outdated:
Magestore_Rewardpoints schema: current version - none, required version - 1.2.0.5
Magestore_Rewardpoints data: current version - none, required version - 1.2.0.5

Exception #0 (Magento\Framework\Exception\LocalizedException): Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory.
The following modules are outdated:
Magestore_Rewardpoints schema: current version - none, required version - 1.2.0.5
Magestore_Rewardpoints data: current version - none, required version - 1.2.0.5
<pre>#1 Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(&Magento\Framework\App\Request\Http#000000007f23423700000000495edb1c#) called at [vendor/magento/module-page-cache/Model/App/FrontController/BuiltinPlugin.php:69]
#2 Magento\PageCache\Model\App\FrontController\BuiltinPlugin->aroundDispatch(&Magento\Framework\App\FrontController\Interceptor#000000007f23439900000000495edb1c#, &Closure#000000007f2343f800000000495edb1c#, &Magento\Framework\App\Request\Http#000000007f23423700000000495edb1c#) called at [vendor/magento/framework/Interception/Interceptor.php:135]
#3 Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(&Magento\Framework\App\Request\Http#000000007f23423700000000495edb1c#) called at [vendor/magento/framework/Interception/Interceptor.php:153]
#4 Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', array(&Magento\Framework\App\Request\Http#000000007f23423700000000495edb1c#), array(array('page_cache_from_...', 'storeCookieValid...', 'install', 'configHash'), array('front-controller...'), 'requestPreproces...')) called at [generated/code/Magento/Framework/App/FrontController/Interceptor.php:26]
#5 Magento\Framework\App\FrontController\Interceptor->dispatch(&Magento\Framework\App\Request\Http#000000007f23423700000000495edb1c#) called at [vendor/magento/framework/App/Http.php:116]
#6 Magento\Framework\App\Http->launch() called at [generated/code/Magento/Framework/App/Http/Interceptor.php:24]
#7 Magento\Framework\App\Http\Interceptor->launch() called at [vendor/magento/framework/App/Bootstrap.php:261]
#8 Magento\Framework\App\Bootstrap->run(&Magento\Framework\App\Http\Interceptor#000000007f23424100000000495edb1c#) called at [index.php:39]
</pre>

 

2 REPLIES 2
Highlighted

Re: Magento 2.3.4 Undefined index: decimal(12,4) NOT NULL default 0

Hi @eric09gmai5796 

To solve this issue, please do following steps:

 

1. Try to get the latest extension code. Run CLI command in the Magento root directory:

 

composer install

2. Try to upgrade your database. Run CLI command:

 

 

php bin/magento setup:upgrade

3. If step 1 and 2 didn't help, then navigate to your database and run this SQL Query (don't forget to change the text in bold):

 

 

 

UPDATE `table_prfix_setup_module` 
 SET schema_version="z.z.z", data_version="z.z.z"
 WHERE  module="Vendor_Module";

NOTE: Replace "Vendor_Module" with your module name.
"table_prfix_" can be found in app/etc/env.php, note that it can be empty.

 

 

Highlighted

Re: Magento 2.3.4 Undefined index: decimal(12,4) NOT NULL default 0

EDIT: Nevermind I found the version. I tried all three steps, none of these worked.