cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.3.5-p1 Composer Broken

Highlighted

Magento 2.3.5-p1 Composer Broken

I'm trying to install a module through composer but it seems that the Magento 2 requirements for the Amazon payment module are not able to be satisfied. Any ideas how I can get round this?

 

bash-4.2$ composer require xtento/module-stockimport
Using version ^2.9 for xtento/module-stockimport
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package magento/product-community-edition (locked at 2.3.4, required as 2.3.5-p1) is satisfiable by magento/product-community-edition[2.3.4] but these conflict with your requirements or minimum-stability.
  Problem 2
    - Conclusion: remove magento/product-community-edition 2.3.5-p1
    - Installation request for magento/product-community-edition 2.3.5-p1 -> satisfiable by magento/product-community-edition[2.3.5-p1].
    - Conclusion: don't install amzn/amazon-pay-and-login-magento-2-module 3.3.1
    - magento/product-community-edition 2.3.5-p1 requires amzn/amazon-pay-and-login-magento-2-module 3.4.1 -> satisfiable by amzn/amazon-pay-and-login-magento-2-module[3.4.1].
    - Can only install one of: amzn/amazon-pay-and-login-magento-2-module[3.3.1, 3.4.1].
    - Can only install one of: amzn/amazon-pay-and-login-magento-2-module[3.4.1, 3.3.1].
    - Installation request for amzn/amazon-pay-and-login-magento-2-module (locked at 3.3.1) -> satisfiable by amzn/amazon-pay-and-login-magento-2-module[3.3.1].


Installation failed, reverting ./composer.json to its original content.

  

Nevermind, fixed this with a composer update!

3 REPLIES 3
Highlighted

Re: Magento 2.3.5-p1 Composer Broken

Hi @benwebstraae83 

Try this :

composer require magento/product-community-edition:2.3.5-p1 --no-update
composer require tig/postnl-magento2 --no-update
composer update

It may help you to resolve issue.

If issue resolve, please click on 'Kudos' & Accept as Solution! 

Highlighted

Re: Magento 2.3.5-p1 Composer Broken

Hello @benwebstraae83 

 

composer remove magento/product-community-edition --no-update

then 

composer require magento/product-community-edition:2.3.5-p1 --no-update

 

composer update


hope it will help you.


Problem solved? Click Kudos & Accept as Solution!
Sunil Patel
Magento 2 Certified Professional Developer & Frontend Developer
Highlighted

Re: Magento 2.3.5-p1 Composer Broken

Hi @benwebstraae83 ,

 

If you want to update your Magento version to the latest version (2.3.5-p1). you can follow @Sunil Patel and @Bhanu Periwal comments.

 

But if you only want to install a new module on the same Magento version, try below command

composer require xtento/module-stockimport --no-update

composer update

 

Thanks!

Problem Solved! Click Kudos & Accept as Solution!