Showing results for 
Search instead for 
Did you mean: 

Magento 2.4.1 searchable attribute not working

Magento 2.4.1 searchable attribute not working


In my project, the searchable attribute values are not coming in the frontend result page.

Since we used custom modules it may affect the magento core function, So I've tried in fresh magento installation without any custom modules.

  1. Installed fresh copy of Magento 2.4.1
  2. Created an attribute called searchable_sku and selected Yes for Use in Search
  3. Added that attribute under Default Attribute Set
  4. Then created two products with one with the value as coolone and another with cooltwo
  5. After this, I ran reindex and it is successful
  6. Then in store front end, when I'm searching for cool I'm not getting any result but if try with SKU I'm getting results
  7. Then I changed the SKU attribute as non searchable attribute
  8. Reindex done
  9. Again when I'm searching with SKU it's giving result and not giving result with cool

It seems to be a big issue, the magento functionality is not even working.

Please give me the fix.


Re: Magento 2.4.1 searchable attribute not working

@Vishnu N 

First of all, make sure that your elastic search is working properly.

If it's not working then contact your server team to get it worked.

If it is working properly then try using below commands:

php bin/magento cache:flush
php bin/magento indexer:reset
php bin/magento indexer:reindex
Problem solved? Click Kudos and "Accept as Solution".
200+ Magento 2 Extensions for Enhanced Shopping Experience.

Re: Magento 2.4.1 searchable attribute not working

Yes ES is working fine, and I tried these steps.

No luck... Are a=you saying that this feature is working in magento 2.4.1?