cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2 Cron Issues "One or more indexers are invalid. Make sure your Magento cron job is running"

Magento 2 Cron Issues "One or more indexers are invalid. Make sure your Magento cron job is running"

I have an existing Magento 1.9x site but I am looking to upgrade to Magento 2 

 

I'm hosting on a cpanel webserver and installed Magento 2.2.4 as fresh install to start looking at it and getting my head around any changes.

 

However, I am having massive issues with being unable to run cron, so other than having added one demo product I cannot do anything else at this stage. The product I added is visible through search, but I cannot see any menus or categories, which I am presuming is down to the indexing / cron issue.

 

I have followed the steps outlined here but that still doesn't get cron to run.

 

Google led me to steps where adding a manual cron job in cpanel was suggested which I also tried. Using the following settings:

 

* * * * * /usr/bin/php /home/doublegm/public_html/crsautomotive.co.uk/onlinestore/bin/magento setup:cron:run >> /home/doublegm/public_html/crsautomotive.co.uk/onlinestore/var/log/setup.cron.log

 

* * * * * /usr/bin/php /home/doublegm/public_html/crsautomotive.co.uk/onlinestore/update/cron.php >> /home/doublegm/public_html/crsautomotive.co.uk/onslinestore/var/log/update.cron.log

 

* * * * * /usr/bin/php /home/doublegm/public_html/crsautomotive.co.uk/onlinestore/bin/magento cron:run | grep -v "Ran jobs by schedule" >> /home/doublegm/public_html/crsautomotive.co.uk/onlinestore/var/log/magento.cron.log

 

But although these show up when executing crontab -l in Putty no indexing etc. occurs on the new install.

 

Pretty much at a loss as to how to proceed from here.

 

1 REPLY

Re: Magento 2 Cron Issues "One or more indexers are invalid. Make sure your Magento cron job is

Update: On top of this I've been unable to even add a theme. 

 

The steps in the help for that don't appear to work either. 

 

Loved Magento 1 and it was a great platform for me, but either 2 is too complex for me to be able to understand and use or it's flawed. 

 

Uninstalled 2 now and going to persevere with 1.9 while looking at other options for the long term.