cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2 - cache_invalidate issues

Magento 2 - cache_invalidate issues

Hello all,

 

I recently managed to migrate data from Magento 1.9.2.2 over to Magento 2.2.5. All the data seemed to migrate over correctly and Magento 2.2.5 was working well.

 

However, recently I was having trouble getting one of our 'Cart rules' to work and no matter what I tried I could not get it to work... despite my best efforts.

 

It seems however, something I have done has managed to cause me greater problems. All of a sudden if I am in admin, go to Catalog, Products and then click on a product I am getting an error 500.

 

Debug.log reports the following:
main.DEBUG: cache_invalidate:  {"method":"GET","url":"http:/","invalidateInfo":{"tags":["interception","CONFIG"],"mode":"matchingTag"}} []
.../var/log/   isn't giving me any other notifications or errors.

 

 

Naturally I have tried clearing the caches but nothing seems to get this working, I still get the error 500.

 

I have no extensions installed yet, only a custom child theme which uses Luma as the parent. The theme changes very little other than some CSS via _extend.less.

 

To ensure my theme was not causing me issues I have tried switching the theme back to Magento Blank, this is where things get very strange, no matter what processes I do I cannot get Magento to change the theme back to Magento Blank... It continues to load my custom Theme which is located in 'App/Design/Frontend/', as I read it should be.

 

Here are the things I have tried:

/pub/static      -  Delete everything except HTACCESS
/var/cache      -  Delete all contents
/var/page_cache      -  Delete all contents
/var/composer_home      -  Delete all contents
/var/page_cache       -  Delete all contents
/var/view_preprocessed        -  Delete all contents

 

I have also tried the following commands in shell lots and lots of times in various orders:

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy

php bin/magento cache:clean
php bin/magento cache:flush
php bin/magento indexer:reindex

 

I even resorted to trying to reset the theme through PhpMyAdmin using the instructions here:  https://devdocs.magento.com/guides/v2.0/howdoi/troubleshoot/reset_theme.html

If you need to reset the store theme, but cannot access the Admin panel, you can reset it in the database by doing the following:

  1. Use a database tool such as phpMyAdmin or access the DB manually from the command line to execute the following SQL query:
    UPDATE core_config_data SET value=NULL WHERE path='design/theme/theme_id'
     
  2. Clear the pub/static/frontend, var/view_preprocessing, var/cache, var/page_cache directories.

 

After doing this I once again tried all the previous processes (folder clearing and commands) multiple times with no success. Magento continues to use the previously assigned custom theme (despite being changed in the database) and I still get the error 500 screen when clicking on products in Catalog, Products

 

I apologise if I am missing something very obvious but I am new to Magento 2. Are there any Magento gurus out there that can possibly explain this?

 

Thanks in advance. Smiley Happy

 

EDIT:  Just to add, I have mostly been trying to resolve this in developer mode.

Tags (1)