cancel
Showing results for 
Search instead for 
Did you mean: 

Magento CLI - set error handler

Magento CLI - set error handler

We run the following command:

vg@c7463 [~]# /usr/local/php56/bin/php-cli /home/vg/public_html/bin/magento setup:cron:run

This is the output we get:

 

Warning: set_error_handler() expects parameter 2 to be long, string given in /home/vg/public_html/bin/magento on line 21
setup-cron: Please check var/log/update.log for execution summary.

The var/log/update.log shows:

 

setup-cron.ERROR: Your current PHP memory limit is 128M. Magento 2 requires it to be set to 756M or more. As a user with root privileges, edit your php.ini file to increase memory_limit. (The command php --ini tells you where it is located.) After that, restart your web server and try again. [] []
 
We have then updated the memory to 756M but same issue continues,
Our hosting support has told us to run the command to avoid the memory_limit warning message:

 

/usr/local/php56/bin/php-cli -d memory_limit=756M /home/vg/public_html/bin/magento setup:cron:run
However we are still getting the same error:
 
Warning: set_error_handler() expects parameter 2 to be long, string given in /home/vg/public_html/bin/magento on line 21
 
Any help would be greatly appreciated 
Tags (1)