cancel
Showing results for 
Search instead for 
Did you mean: 

Magento does not generate statics

Magento does not generate statics

Hello, I'm having issue with my Magento instance on production server. I've created the app and database on my localhost and afterwards transfered it to the production. But I'm unable to run it properly, static does not generate for frontend nor backend.

 

Url: 

https://growtop.pl/

 

Specs:

Magento 2.4.3

PHP FPM 7.4

Nginx

server
{
  set $MAGE_ROOT /var/www/bws/growtop.pl;
  root $MAGE_ROOT;
  server_name growtop.pl www.growtop.pl;

  if ($host = www.growtop.pl)
  {
    return 301 https://growtop.pl$request_uri;
  }

  index index.php;
  autoindex off;
  charset UTF-8;
  error_page 404 403 = /errors/404.php;
  #add_header "X-UA-Compatible" "IE=Edge";


  # Deny access to sensitive files
  location /.user.ini
  {
    deny all;
  }

  # PHP entry point for setup application
  location ~* ^/setup($|/)
  {
    root /var/www/bws/growtop.pl;
    location ~ ^/setup/index.php
    {
      fastcgi_pass unix:/var/run/php/php7.4-fpm.sock;

      fastcgi_param PHP_FLAG "session.auto_start=off \n suhosin.session.cryptua=off";
      fastcgi_param PHP_VALUE "memory_limit=756M \n max_execution_time=600";
      fastcgi_read_timeout 600s;
      fastcgi_connect_timeout 600s;

      fastcgi_index index.php;
      fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
      include fastcgi_params;
    }

    location ~ ^/setup/(?!pub/).
    {
      deny all;
    }

    location ~ ^/setup/pub/
    {
      add_header X-Frame-Options "SAMEORIGIN";
    }
  }

  # PHP entry point for update application
  location ~* ^/update($|/)
  {
    root $MAGE_ROOT;

    location ~ ^/update/index.php
    {
      fastcgi_split_path_info ^(/update/index.php)(/.+)$;
      fastcgi_pass unix:/var/run/php/php7.4-fpm.sock;
      fastcgi_index index.php;
      fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
      fastcgi_param PATH_INFO $fastcgi_path_info;
      include fastcgi_params;
    }

    # Deny everything but index.php
    location ~ ^/update/(?!pub/).
    {
      deny all;
    }

    location ~ ^/update/pub/
    {
      add_header X-Frame-Options "SAMEORIGIN";
    }
  }

  location /
  {
    try_files $uri $uri/ /index.php$is_args$args;
  }

  location /pub/
  {
    location ~ ^/pub/media/(downloadable|customer|import|custom_options|theme_customization/.*\.xml)
    {
      deny all;
    }
    alias $MAGE_ROOT/pub/;
    add_header X-Frame-Options "SAMEORIGIN";
  }

  location /static/
  {
    location ~ ^/static/version
    {
      rewrite ^/static/(version\d*/)?(.*)$ /static/$2 last;
    }

    location ~* \.(ico|jpg|jpeg|png|gif|svg|js|css|swf|eot|ttf|otf|woff|woff2|html|json)$
    {
      add_header Cache-Control "public";
      add_header X-Frame-Options "SAMEORIGIN";
      expires +1y;

      if (!-f $request_filename)
      {
        rewrite ^/static/(version\d*/)?(.*)$ /static.php?resource=$2 last;
      }
    }
    location ~* \.(zip|gz|gzip|bz2|csv|xml)$
    {
      add_header Cache-Control "no-store";
      add_header X-Frame-Options "SAMEORIGIN";
      expires off;

      if (!-f $request_filename)
      {
        rewrite ^/static/(version\d*/)?(.*)$ /static.php?resource=$2 last;
      }
    }
    if (!-f $request_filename)
    {
      rewrite ^/static/(version\d*/)?(.*)$ /static.php?resource=$2 last;
    }
    add_header X-Frame-Options "SAMEORIGIN";
  }

  location /media/
  {
    try_files $uri $uri/ /get.php$is_args$args;

    location ~ ^/media/theme_customization/.*\.xml
    {
      deny all;
    }

    location ~* \.(ico|jpg|jpeg|png|gif|svg|js|css|swf|eot|ttf|otf|woff|woff2)$
    {
      add_header Cache-Control "public";
      add_header X-Frame-Options "SAMEORIGIN";
      expires +1y;
      try_files $uri $uri/ /get.php$is_args$args;
    }
    location ~* \.(zip|gz|gzip|bz2|csv|xml)$
    {
      add_header Cache-Control "no-store";
      add_header X-Frame-Options "SAMEORIGIN";
      expires off;
      try_files $uri $uri/ /get.php$is_args$args;
    }
    add_header X-Frame-Options "SAMEORIGIN";
  }

  location /media/customer/
  {
    deny all;
  }

  location /media/downloadable/
  {
    deny all;
  }

  location /media/import/
  {
    deny all;
  }

  location /media/custom_options/
  {
    deny all;
  }

  location /errors/
  {
    location ~* \.xml$
    {
      deny all;
    }
  }

  # PHP entry point for main application
  location ~ ^/(index|get|static|errors/report|errors/404|errors/503|health_check)\.php$
  {
    try_files $uri =404;
    fastcgi_pass unix:/var/run/php/php7.4-fpm.sock;
    fastcgi_buffers 16 16k;
    fastcgi_buffer_size 32k;

    fastcgi_param PHP_FLAG "session.auto_start=off \n suhosin.session.cryptua=off";
    fastcgi_param PHP_VALUE "memory_limit=756M \n max_execution_time=18000";
    fastcgi_read_timeout 600s;
    fastcgi_connect_timeout 600s;

    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include fastcgi_params;
  }

  gzip on;
  gzip_disable "msie6";

  gzip_comp_level 6;
  gzip_min_length 1100;
  gzip_buffers 16 8k;
  gzip_proxied any;
  gzip_types
  text/plain
  text/css
  text/js
  text/xml
  text/javascript
  application/javascript
  application/x-javascript
  application/json
  application/xml
  application/xml+rss
  image/svg+xml;
  gzip_vary on;

  # Banned locations (only reached if the earlier PHP entry point regexes don't match)
  location ~* (\.php$|\.phtml$|\.htaccess$|\.git)
  {
    deny all;
  }

  listen 443 ssl; # managed by Certbot
  ssl_certificate /etc/letsencrypt/live/growtop.pl/fullchain.pem; # managed by Certbot
  ssl_certificate_key /etc/letsencrypt/live/growtop.pl/privkey.pem; # managed by Certbot
  include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
  ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}

 

Things I've tried:

  • find . -type f -exec chmod 644 {} \;
    find . -type d -exec chmod 755 {} \;
    find ./var -type d -exec chmod 777 {} \;
    find ./pub/media -type d -exec chmod 777 {} \;
    find ./pub/static -type d -exec chmod 777 {} \;
    chmod 777 ./app/etc
    chmod 644 ./app/etc/*.xml
    chown -R www-data:www-data /var/www/app
    chmod u+x bin/magento
  • rm -rf var/cache/* var/generation/* var/page_cache/* var/di && php -f bin/magento cache:flush && php -f bin/magento setup:upgrade
1 REPLY 1

Re: Magento does not generate statics

@jakubskapsd7ff 

It will be set up properly in the live if you use the steps mentioned in the below link:

https://meetanshi.com/blog/install-magento-2-4-2-on-localhost-using-xampp/

 

Problem solved? Click Kudos and "Accept as Solution"