cancel
Showing results for 
Search instead for 
Did you mean: 

My Magento 2 is extremely slow

My Magento 2 is extremely slow

Hi, I installed Magento 2 on a VPS with 3 Gb RAM and 2x2Ghz cpu, centos 6.7, apache 2, php 5.6 mysql 5.6 and is loading extremely slow. More that 20 seconds for first visit, and then is loading in 1s from cache.

Anyone who can help me?

 

Any advice will be appreciated.

 

Thank You.

9 REPLIES

Re: My Magento 2 is extremely slow

Caching definitely should be enabled in production mode so your store visitors  will be OK.

Disabling the cache has a sense for some development tasks only, and a developer should use a performant hardware to increase his productivity. I recommend SSD and more RAM for development.

Re: My Magento 2 is extremely slow

i've just 1 bg ram and its extremely fast Smiley Happy i m on https://www.digitalocean.com/ 

Re: My Magento 2 is extremely slow

I know that it should be faster. I think my issue is happening because of my server configuration ( maybe mysql conifg)

Re: My Magento 2 is extremely slow

I have the same issue

 

The performance was better after changing the MAGE_MODE variable into your apache or nginx configuration:

 

set $MAGE_MODE production;   # default or production or developer

 

If you know how to enable memcache, I am interresting.

 

Nicolas

 

Re: My Magento 2 is extremely slow

you have here a step by step guide to install, configure and test memcache 

 

http://devdocs.magento.com/guides/v2.0/config-guide/memcache/memcache.html

Re: My Magento 2 is extremely slow

jalnet, I have tested again and It is working now. thanks.

 

For the slowness issue, you can check using firebug; I had 404 errors.

 

After rebuilding the static content, It is working now:

# ./bin/magento setup:static-content:deploy

 

Nicolas

 

 

Re: My Magento 2 is extremely slow

what is your website url? 

 

scan it with www.gtmetrix.com to see what is going on

Re: My Magento 2 is extremely slow

how can we change magento mode without command line, and through files, and where to find mage-mode ?

Re: My Magento 2 is extremely slow

If you don't have command line access then you can change the mode by either setting in the webserver environment or php-fpm environment.

 

For webserver:

open .htaccess file in the web root

Type SetEnv MAGE_MODE production

 

Take a look at this  for more details