cancel
Showing results for 
Search instead for 
Did you mean: 

One or more indexers are invalid. Make sure your Magento cron job is running.

SOLVED

One or more indexers are invalid. Make sure your Magento cron job is running.

Good day!

 

I installed Magento 2.2.4 through cpanel-softaculous in a localhost. the message "One or more indexers are invalid. Make sure your Magento cron job is running." appears so I want to solve it, however video tutorials and other stuff are for people who installed it manually. the installation files are in file manager. How can I fix this? PLEASE HELP MEcc.JPGcc.JPG nn.JPGnmb.JPG

7 REPLIES

Re: One or more indexers are invalid. Make sure your Magento cron job is running.

Hi @CMX1

 

okay i understand the problem ! you need to run reindex command to resolved the issue !

 

Open your ssh terminal by entering details then go to your magento 2 root directory !

 

Then run below commands in sequence :

 

 

php bin/magento indexer:reindex
php bin/magento cache:clean
php bin/magento cache:flush

 

You can also change indexer settings to Update on Save - so it will automatically reindex when you save something !

 

It will works !

 

if issue solved,Click Kudos & Accept as Solution

Re: One or more indexers are invalid. Make sure your Magento cron job is running.

Thank you, only one thing more, how do I open ssh terminal? (More details I using cpanel  and windows 10) sorry Im  beginner in this and I dont have experience with programming stuff.

Re: One or more indexers are invalid. Make sure your Magento cron job is running.

Hi @CMX1

 

i understand your concern - To open SSH terminal there is two option 

 

1 ) as you are using windows system so you required PUTTY application on your windows - in putty you need to add your server ip/hostname then port number and username and password !

 

then you will able to connect your magento 2 directory of your server !

 

2) You can ask your hosting provider - they might have given option in cPanel itself to access SSH terminal - then you can directly connect to SSH panel for the same !

 

Hope it helps to you !

if issue solved,Click Kudos & Accept as Solution

Re: One or more indexers are invalid. Make sure your Magento cron job is running.

well I accessed to putty ssh and that stuff and logged in. How do I go to my directory?cc.JPG

I checked in softaculous magento installation details and it has: cc.JPG

and even has something called route that is the same that directory I think. So how do I type that stuff in ssh? I dont know anything of programming.

Re: One or more indexers are invalid. Make sure your Magento cron job is running.

Hi @CMX1

 

Looks like your screenshot is not visible to us !

 

Still - if you are logged in to your SSH panel - then you need to use CD command to go into your magento 2 root directory !

 

First you need to identify the path of magento 2 root directory then type command in SSH terminal like below : 

 

cd /var/www/html/magento2rootdirectory

 

Then once you are in magento 2 root directory , then you need to write command over there like below :

 

php bin/magento indexer:reindex

 

You can also take a help of your hosting provider for  the same as its slight technical so

Then it will works !

if issue solved,Click Kudos & Accept as Solution

Re: One or more indexers are invalid. Make sure your Magento cron job is running.

Thank you, but it worked finally doing the next thing:

 

Using putty-ssh after I set my magento directory I typed "/opt/php70/bin/php bin/magento indexer:reindex"

 

the thing is that cpanel has php version 5.6 default and I just could change to 7.1, but partially so I had to run it in this way.

 

It was a different case. Anyways Thank you!

Re: One or more indexers are invalid. Make sure your Magento cron job is running.

Hi @CMX1

 

Glad to know that you have resolved your issue and sharing the details for the same ! Happy to help and keep helping Smiley Happy

if issue solved,Click Kudos & Accept as Solution