cancel
Showing results for 
Search instead for 
Did you mean: 

Order emails are not automated

Order emails are not automated

Hi team Magento

 

On my site, Order confirmations / invoices / shipping confirmation emails are only sending when the administrator manually sends these from the backend, not automatically on completion.

 

Is this normal? I have Magento 2.3.5-p1

 

The payment gateway is PayFast.

 

 

3 REPLIES 3

Re: Order emails are not automated

Hi @katheriner7033 

Kindly follow below steps :

1. On the Admin Panel, Stores > Settings > Configuration.
2. On the left panel, under Sales tab, click on Sales Emails subtab.
3. Open the Order section:
4. Set Yes to enable the Sales Emails.
5. Choose the store contact of the email in the New Order Confirmation Email field.
6. Choose the desire email template that is sent to registered customers in the New Order Confirmation Template field.
7. Choose the email template in the New Order Confirmation Template for Guests that is sent to those who don’t create an account on your store.
8. To send the sales emails to many people at the same time, enter the email addresses in the Send Order Email Copy To field, and each is separated by comma.
9. Choose one of the sending email methods in the Send Order Email Copy Method:
10. BCC: Send a “blind courtesy copy” by including other recipient(s) in the header of the same email that is sent to the customer. The BCC recipient is not visible to the customer and he/she doesn’t know that a copy is sent to many addresses.
11. Separate Email: Send a copy email as a separate email.
12. Open the Order Comments, Invoice, Shipment, and Credit Memo section, then complete it similarly to Order.
13. Save Config to finish the Sales Email configuration.

Or You can refer below link :
https://www.mageplaza.com/kb/how-to-configure-sales-email-magento-2.html

It may help you.
If issue resolve, please click on 'Kudos' & Accept as Solution!

Re: Order emails are not automated

Hi @katheriner7033 ,

 

Can you please cross check mailing settings in your Magento instance:

Go to Stores -> Configuration -> Advanced -> System

Under Mail Sending Settings make sure -  Disable Email Communications is set to No.

Also, verify your Host and Port fields if you are using any external mailing server.

 

Go to Stores -> Configuration -> Sales -> Sales Emails

Under the General Settings tab, choose Asynchronous sending to Disable

Under Order tab Enabled to Yes

 

Now clear/refresh your cache.

 

Also after all the settings check, check for the cron settings as well which Magento suggested.

https://devdocs.magento.com/guides/v2.2/install-gde/install/post-install-config.html

 

Hope it helps you!

Problem Solved! Click Kudos & Accept as Solution! 

Re: Order emails are not automated

Thanks for the advice. There was an additional config on the Payfast gateway that was stopping the generation of invoice emails though.