cancel
Showing results for 
Search instead for 
Did you mean: 

Problem install stripe on Magento 2.3.2

Problem install stripe on Magento 2.3.2

I have a problem to finish installing Stripe
By running the composer require stripe/stripe-php:^7 command from root, I get this message:

The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Do not run Composer as root/super user! See https://getcomposer.org/root for details

How to solve the problem without creating problems in Magento ?

7 REPLIES 7

Re: Problem install stripe on Magento 2.3.2

Hi @lugotek ,

 

Can you try installing module using composer with the help of below Url.

https://stripe.com/docs/plugins/magento/install

 

Also can you mention what is the PHP version on which you are trying to install the stripe plugin. recently i checked on the PHP 7.3.24 and it works smooth for me.

 

Hope this helps you!

Problem Solved! Click Kudos & Accept as Solution!

 

Re: Problem install stripe on Magento 2.3.2

Hey @lugotek,

 

You can use the below command to install stripe

composer require stripe/stripe-payments --no-plugins

 

 

Re: Problem install stripe on Magento 2.3.2

Hello.
Thank you for your answer. But with this command you do not risk updating any components of Magento anyway or is only installed the library necessary to make stripe work ?

Re: Problem install stripe on Magento 2.3.2

Can someone answer me please ?

Re: Problem install stripe on Magento 2.3.2

Hi @lugotek ,

 

Please answer below questions:

1. You only want to install stripe library. ?

2. what is PHP version on which you are installing the library.?

 

Have you tried steps mentioned in the below link using composer?

https://stripe.com/docs/plugins/magento/install

 

Thanks!

Re: Problem install stripe on Magento 2.3.2

I have a problem to finish installing Stripe
By running the composer require stripe/stripe-php:^7 command from root, I get this message:

The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Do not run Composer as root/super user! See https://getcomposer.org/root for details

How to solve the problem without creating problems in Magento ?

Re: Problem install stripe on Magento 2.3.2

Hi @lugotek ,

 

Can you try below command to downgrade your composer version 

 

You can simply run composer self-update version_number
Example:composer self-update 1.10.0

You can check composer available versions here https://getcomposer.org/download/

 

 

Hope this helps you!

Problem Solved! Click Kudos & Accept as Solution!