cancel
Showing results for 
Search instead for 
Did you mean: 

Product 'created_at' time incorrect in flat index 'catalog_product_flat' vs 'catalog_product_entity'

Product 'created_at' time incorrect in flat index 'catalog_product_flat' vs 'catalog_product_entity'

Running CE 2.1.4

I created a custom sort by 'Newest' for the front-end according to this but the times listed for 'created_at' in 'catalog_product_flat_1' are wrong. A bunch of the items in the flat table have a 'created_at' time from when the indexer was run as opposed to the actual creation time of the product. For example in 'catalog_product_entity' the product sku "SK-Navy" has 'created_at' value of 2016-10-31 but after indexer generates the flat catalog the table 'catalog_product_entity' this product has a 'created_at' value of 2017-04-14, which obviously is when I ran the indexer. Especially odd is that it doesnt happen for all products, most of them have the same time in both places as you would expect...

 

This problem totally breaks my sorting functionality. Does anyone have any idea on how to fix something like this?

 

Thanks for any help

1 REPLY

Re: Product 'created_at' time incorrect in flat index 'catalog_product_flat' vs 'catalog_product_ent

You've probably solved it by now, but for other people: I had this issue as well.

The solution can be found here: 

https://stackoverflow.com/questions/8131725/timestamp-without-change-on-update

 

You have to configure mysql with settiing 

explicit_defaults_for_timestamp = 1