cancel
Showing results for 
Search instead for 
Did you mean: 

Result-page not showing results

Result-page not showing results

Hi all,

Since a few days there are no results showing on the results-page and I'm not sure whats causing this.

LayeredNavigation is active and shows data in de sidebar what means there are products found, but the right column is empty.

 

Schermafbeelding 2017-08-30 om 09.48.15.png

 

This is the HTML-output.

The sidebar contains the results (attributes like color and size) but "column main" is pretty empty.

Schermafbeelding 2017-08-30 om 09.49.03.png

 

This is the output of the template path hints in case it's helpful:

Schermafbeelding 2017-08-30 om 09.53.58.png

 

Does anyone have an idea what could go wrong?

I'm using Magento 2.1.4 and the Porto theme of Smartwave.

 

Thanks in advance!

Wouter

2 REPLIES

Re: Result-page not showing results

It could be that there's a PHP error that's causing the output of products to fail. Have you checked the logs after turning on logging to the most sensitive level?

 

You could also try switching back to the default theme to see if it's something in the theme.

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: Result-page not showing results

Hi, thanks for replying.

 

In the log I see this error when searching:

main.CRITICAL: Invalid method Magento\Framework\View\Element\Template::isContentMode [] []

 

An other error I got was regarding the StripTags function in the Filter of Magento.

The variable that is checked by strip_tags was an array, not a string.
I solved this by using a simple check:

if(is_array($value))
{
       $value = implode($value);
}

I think it's weird because the search-component and this "isContentMode" is not changed at all.