cancel
Showing results for 
Search instead for 
Did you mean: 

SSH error: magento must be run as a CLI application

SOLVED

SSH error: magento must be run as a CLI application

Hello,

Any magento command I try returns the following error:

 

Content-type: text/html

bin/magento must be run as a CLI applicationbash-3.2$

Here's my PHP info:

PHP 5.4.42 (cgi-fcgi) (built: Jun 16 2015 14:54:07)

I'm new to web development so I'm probably missing something but I just can't figure out how to fix this. How do I change my PHP from cgi to cli? Any suggestions will be greatly appreciated.

 

3 REPLIES

Re: SSH error: magento must be run as a CLI application

Hi,

upgrade you PHP >= 5.6 or higher. Check below for more detail.

Magento2 system requirements

Re: SSH error: magento must be run as a CLI application

123

Re: SSH error: magento must be run as a CLI application

Hi @Daniel_BPT,

Magento2 is not compatible with PHP version 5.4.x. You should use PHP version 7.0.x to install Magento2 website. 

www.advancedcheckout.com - www.stableaddon.com
One Step checkout extension - Social Login extension - Gift Card extension