cancel
Showing results for 
Search instead for 
Did you mean: 

Safe to uninstall Data Migration tool?

Safe to uninstall Data Migration tool?

I upgraded from 1.9 to 2.1.6 a few months back using the data migration tool, then upgraded to 2.1.8 successfully. After that I disabled the Data Migration module.

 

I am now trying to upgrade to 2.1.9 using the System Upgrade screen in the backend and I see this weird message during the Readiness check: "We're making sure your server environment is ready for Magento_DataMigrationTool to be upgraded." (see screenshot)capture.png

 

Is it safe to uninstall the data migration module completely? Do I need to edit my composer.json file first for the "require" part? Apologies, I am not a developer.

 

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.1.3",
"license": [
"OSL-3.0",
"AFL-3.0"
],
"require": {
"magento/product-community-edition": "2.1.8",
"composer/composer": "@alpha",
"magento/data-migration-tool": "2.1.3",
"omise/omise-php": "2.7.1"
},
"require-dev": {
"phpunit/phpunit": "4.1.0",
"squizlabs/php_codesniffer": "1.5.3",
"phpmd/phpmd": "@stable",
"pdepend/pdepend": "2.2.2",
"fabpot/php-cs-fixer": "~1.2",
"lusitanian/oauth": "~0.3 <=0.7.0",
"sebastian/phpcpd": "2.0.0"
},

2 REPLIES

Re: Safe to uninstall Data Migration tool?

I'm wondering the same.  Did you figure it out?  Thank you.

Re: Safe to uninstall Data Migration tool?

I backed-up my site and tried uninstalling the data migration tool using the command below, but it blew up my site, so don't do it!

 

composer remove magento/data-migration-tool

 

I'm still looking for a solution to upgrade Magento beyond 2.1.9.  When I try to upgrade via command line, I get the following result:

 

-------------

 

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don't install monolog/monolog 1.23.0
- Conclusion: don't install monolog/monolog 1.22.1
- Conclusion: don't install monolog/monolog 1.22.0
- Conclusion: don't install monolog/monolog 1.21.0
- Conclusion: don't install monolog/monolog 1.20.0
- Conclusion: don't install monolog/monolog 1.19.0
- Conclusion: don't install monolog/monolog 1.18.2
- Conclusion: don't install monolog/monolog 1.18.1
- Conclusion: don't install monolog/monolog 1.18.0
- Conclusion: don't install monolog/monolog 1.17.2
- Installation request for magento/data-migration-tool 2.1.8 -> satisfiable by magento/data-migration-tool[2.1.8].
- Conclusion: don't install monolog/monolog 1.17.1
- magento/product-community-edition 2.2.1 requires monolog/monolog ^1.17 -> satisfiable by monolog/monolog[1.17.0, 1.17.1, 1.17.2, 1.18.0, 1.18.1, 1.18.2, 1.19.0, 1.20.0, 1.21.0, 1.22.0, 1.22.1, 1.23.0].
- magento/product-community-edition 2.2.1 requires monolog/monolog ^1.17 -> satisfiable by monolog/monolog[1.17.0, 1.17.1, 1.17.2, 1.18.0, 1.18.1, 1.18.2, 1.19.0, 1.20.0, 1.21.0, 1.22.0, 1.22.1, 1.23.0].
- Conclusion: don't install monolog/monolog 1.17.0
- Installation request for magento/product-community-edition 2.2.1 -> satisfiable by magento/product-community-edition[2.2.1].

 

------------

 

This leads me to believe that if I were able to uninstall the Data Migration Tool, the problem would be removed and I would be able to upgrade.  Can anyone advise whether this is correct, or if there's a better solution?  

 

Thanks!