cancel
Showing results for 
Search instead for 
Did you mean: 

Shipping not applying after using a coupon

Shipping not applying after using a coupon

Since I updated to magento 2.3.6 I have a weird bug. To sumarize, we only use tablerates for our shipping. So every order lesser than 40 € is charged with 5€ of shipping charges.

 

It was fine until I updated my magento to 2.3.6, in the following example as you can see an order previous to this update:

 

https://i.stack.imgur.com/Hqbaj.png

 

That was an order of 43,56 €, the customer applied a coupon (cart price rule) in order to discount 20% off (8,71 €). Since the result was lesser than 40 € it automatically added a 5€ charge of shipping. It was working great.

 

Now, since I updated it doesn't do it that way anymore. Here's an order from today:

 

https://i.stack.imgur.com/7AG8t.png

 

In this example the order was 45,06 €, applying the same 20% off code (6,76 €) it ends up in 38,30 €.

 

Since it is less than 40 € it should add another extra 5 € of shipping, which it just doesn`t. I am mad searching from an explanation between total and subtotal but I find nothing at all.

 

Just to sumarize, we don't have flat rate shipping or free shipping activated, we do everything through tablerates since it worked well for us until we updated.

 

Does anyone know what is wrong with it? I changed nothing in the configuration or tablerate since it was working well until we noticed this error today.

 

Thanks a lot in advance, for real,

2 REPLIES 2

Re: Shipping not applying after using a coupon

Hello @george33 

Can you confirm if you have this option enabled and due to that it's happening? 

http://prntscr.com/1dsx3vh

Was my answer helpful? You can accept it as a solution.
150+ professional extensions for M1 & M2 with free lifetime updates!

Re: Shipping not applying after using a coupon

Hi @Gaurav_Jain02 

 

Yes, that option is disabled in every rule.

My tablerate seems something to this:

 

 
So if the subtotal is above 40 € it should be 0, in the other way it should be 5 €. It was working great before updating.
 
Now In the example it looks like this (even with the option of "discard subsequent rules" deactivated:

Before the 2.3.6-p1 patch it worked great, but right now it seems to confuse between total, subtotal and everything else.
 
Yesterday we spent the whole day playing around with the "Free shipping" and cart rules but it is impossible, I don't know what to do anymore.
 
Thanks a lot tho,
 
Best regards