cancel
Showing results for 
Search instead for 
Did you mean: 

So I moved the Price attribute to the Advanced Pricing Group

So I moved the Price attribute to the Advanced Pricing Group

Magento 2.2.2

What a rollercoaster this new Magento is...
so I rearranged some the attributes in the Attribute Set screen for a custom attribute I was creating. I wanted to move the price, price_view and tax_class_id into the Advanced Pricing attribute group. That worked fine, no issues when saving.

 

Now when I go to create a product with this attribute set, everything loads fine, except I noticed there's no Price or Advanced Pricing group/accordion. In Magento 1.9.x I usually finished the price last because it takes a bit of time to work on, so I did the same here. I didn't see it anywhere, so I tried to save. I received no alerts about anything missing, and nor did the product save or refresh the page.

 

I figured something must be wrong with the price being in that attribute group, so I went back and put it back in the Product Details group, saved and tried to make the product again. Now this time, when selecting the product attribute set from the drop down, the page began refreshing for some time, then gave me the error: 

A technical problem with the server created an error. Try again to continue what you were doing. If the problem persists, try again later.
So now, I can't make the product. The worst part is that I already did this to all the other attributes.
Screen Shot 2018-03-08 at 4.01.00 PM.png
 
What can I do? I can't save the products and I can't seem to revert. Is this a known bug, has anyone gone through this before?
Gena Heyward
Developerz Block - Web Developer
1 REPLY

Re: So I moved the Price attribute to the Advanced Pricing Group

So I found this is a bug. https://github.com/magento/magento2/issues/12709

    Product solution: is forbidden to move price, sku and name to other groups for attribute sets.
    Need fix: prohibit the move of these attributes to another group, and display an error message.

 

What I happened to do to solve (for now): I put the Price attribute back into the Product Details group in the Attribute Set, along with the price_view and tax_class_id attributes. This doesn't work alone, I also had to do this change to the Default Attribute Set as well for the Price field to appear again. Waiting on the Magento teams' fix.

Gena Heyward
Developerz Block - Web Developer