cancel
Showing results for 
Search instead for 
Did you mean: 

Theme version errors during update

SOLVED

Theme version errors during update

My Magento2 webstore throws the following error:

a:4:{i:0;s:569:"Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory. 
The following modules are outdated:
Infortis_Infortis schema: current version - 2.6.0, required version - 2.5.0
Infortis_Infortis data: current version - 2.6.0, required version - 2.5.0
Infortis_Base schema: current version - 2.6.3, required version - 2.5.0
Infortis_Base data: current version - 2.6.3, required version - 2.5.0
Infortis_Ultimo schema: current version - 2.6.3, required version - 2.5.0
Infortis_Ultimo data: current version - 2.6.3, required version - 2.5.0";i:1;s:3329:"#0 /home/stagingsvw2/public_html/vendor/magento/framework/Interception/Chain/Chain.php(67): Magento\Framework\Module\Plugin\DbStatusValidator->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#1 /home/stagingsvw2/public_html/vendor/magento/framework/Interception/Chain/Chain.php(63): Magento\Framework\Interception\Chain\Chain->invokeNext('Magento\\Framewo...', 'dispatch', Object(Magento\Framework\App\FrontController\Interceptor), Array, 'front-controlle...')
#2 /home/stagingsvw2/public_html/vendor/magento/module-page-cache/Model/App/FrontController/VarnishPlugin.php(55): Magento\Framework\Interception\Chain\Chain->Magento\Framework\Interception\Chain\{closure}(Object(Magento\Framework\App\Request\Http))
#3 /home/stagingsvw2/public_html/vendor/magento/framework/Interception/Chain/Chain.php(67): Magento\PageCache\Model\App\FrontController\VarnishPlugin->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#4 /home/stagingsvw2/public_html/vendor/magento/framework/Interception/Chain/Chain.php(63): Magento\Framework\Interception\Chain\Chain->invokeNext('Magento\\Framewo...', 'dispatch', Object(Magento\Framework\App\FrontController\Interceptor), Array, 'front-controlle...')
#5 /home/stagingsvw2/public_html/vendor/magento/module-page-cache/Model/App/FrontController/BuiltinPlugin.php(68): Magento\Framework\Interception\Chain\Chain->Magento\Framework\Interception\Chain\{closure}(Object(Magento\Framework\App\Request\Http))
#6 /home/stagingsvw2/public_html/vendor/magento/framework/Interception/Chain/Chain.php(67): Magento\PageCache\Model\App\FrontController\BuiltinPlugin->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#7 /home/stagingsvw2/public_html/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\Interception\Chain\Chain->invokeNext('Magento\\Framewo...', 'dispatch', Object(Magento\Framework\App\FrontController\Interceptor), Array, 'infortis_cgen_m...')
#8 /home/stagingsvw2/public_html/app/code/Infortis/Cgen/Plugin/Magento/Framework/App/FrontController.php(32): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#9 /home/stagingsvw2/public_html/vendor/magento/framework/Interception/Interceptor.php(142): Infortis\Cgen\Plugin\Magento\Framework\App\FrontController->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#10 /home/stagingsvw2/public_html/var/generation/Magento/Framework/App/FrontController/Interceptor.php(26): Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', Array, Array)
#11 /home/stagingsvw2/public_html/vendor/magento/framework/App/Http.php(135): Magento\Framework\App\FrontController\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#12 /home/stagingsvw2/public_html/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http->launch()
#13 /home/stagingsvw2/public_html/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#14 {main}";s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";}

I tried the following:

  1. php bin/magento setup:upgrade
  2. php bin/magento setup:di:compile
  3. Reindex en flush the cache

but the error keeps occuring. Maybe downgrading my theme?

----------------------------------------------------------------------------
PdM internetdiensten voor webwinkels & websites.
1 REPLY

Re: Theme version errors during update

Go to your database and open setup_module table.

 

Now find below entries in it and Delete those entries for the same.

 

 

Infortis_Infortis
Infortis_Infortis 
Infortis_Base 
Infortis_Base 
Infortis_Ultimo
Infortis_Ultimo

 

After deleting above 6 entries , then run below commands :

1) php bin/magento setup:upgrade

2) php bin/magento setup:di:compile

3) php bin/magento setup:static-content:deploy
4) php bin/magento cache:clean
5) php bin/magento cache:flush

if issue solved,Click Kudos & Accept as Solution
Tags (1)