Showing results for 
Search instead for 
Did you mean: 

Watermark not showing

Watermark not showing

Hi to all,


Yesterday I've tried to add a watermark to the store / product images.

(magento 2.2.5) I've added watermark image in jpg and png and tried several options in Content->Design->Config

but nothing is showing up on the frontend, is there anyone having the same issue or able to help me solve this issue?


kind regards and thanks in advanceSmiley Happy


Re: Watermark not showing

Hello @RockMariska


Have you flush catalog image cache from cache management section



Problem solved? Click Kudos & Accept as Solution!
Sunil Patel
Magento 2 Certified Professional Developer & Frontend Developer

Re: Watermark not showing

Hi @Sunil Patel,


Yes I've flushed all caches a couple of times and reindexed, also tried a png made in photoshop and tried jpg. 


Re: Watermark not showing

try to rename pub/media/catalog


cache folder 


and try it.

Problem solved? Click Kudos & Accept as Solution!
Sunil Patel
Magento 2 Certified Professional Developer & Frontend Developer

Re: Watermark not showing

Hi @RockMariska


Well i think the size of watermark image is not in a standard format !


Refer this link for the same -


Create a water mark image on appropriate size and then check !


You can also refer this link , the solution given on this link might help you -


Note : this is just suggestion as you might already have read this block or size might be a perfect !


Hope it helps !

if issue solved,Click Kudos & Accept as Solution

Re: Watermark not showing

Hi @Manthan Dave,


The explanation of the docs.magento is what I've followed. I've created a black tekst/logo in png with size 50x50 .

Since that wasn't working I was wandering if it could be to add a bigger logo and adjust the settings as opacity,size and position in the magento backend.

then I've tried a jpg.

when not changing opacity, the logo should be full color visible, right? opacity makes it blend in with the images.


so I've tried all again and see the images are saved: /pub/media/catalog/product/watermark/website/1 

except the small image is not being saved?


then even after flushing and reindexing there's no watermark.

could it be the file where it write to maybe the issue?

Re: Watermark not showing

Hi @Sunil Patel


what exactly do you mean by  renaming? 

the file where the images watermark are saved is this: pub/media/catalog/product/watermark/websites/1



Re: Watermark not showing

OK, it seems I'm still encountering some magento core issues.

I've tried the watermark on another webste magento 2.1.9 and it is very easy and working perfect on  this website.

Just on the one important I cannot get the Watermark, and also the Captcha is not working on the create account page.

Then I'm also having issues with quantity changer at the product page to change 1 item up to 2 or 3 or more, is not working. Now I've also seen today on mobile I cannot select a product and add to cart.

So somewhere someting is really messed up. Could this happen through extensions that don't work together? Or what would be a way to get these things fixed?


Re: Watermark not showing

@RockMariska the issue for watermarks is not with your server.


I opened a ticket with magento and duplicated the issue on their development server for 2.3.0. 

Re: Watermark not showing

The spring can warm water extremely quick with the 3000-watt warming component made out of excellent copper. For that, best geyser for home use it is outstanding amongst other moment springs in India at this moment.