cancel
Showing results for 
Search instead for 
Did you mean: 

Web Setup Wizard 401 Unauthorised Access

Web Setup Wizard 401 Unauthorised Access

Hi,

 

I've installed Magento 2.04 using the web install method and all running fine (except for some initial redirect loop problems that are I've managed to sort out). 

 

One problem remains in that I cannot access the Web Setup Wizard while the admin is using SSL. If I turn SSL off, I can access it no problem, update our keys etc. However, when I turn on SSL for the admin (as I would in a production environment), when I click on Web Setup Wizard it first redirects to the unsecure setup folder, then I get redirected to a 401 unauthorised access page (/setup/index.php/session/unlogin). I've tried everything I can think of: clearing the cache, browser cache, changing permissions, reinstalling, however I always end up at the same place.

 

The only modification I've made to the .htaccess file in the main magento folder is adding the line "SetEnv HTTPS on" to deal with the redirect loop problems I initially had when using SSL on both the back and frontend, as well as some CSS and javascript loading issues.

 

Any help would be much appreciated - it's driving me crazy!

 

J

3 REPLIES

Re: Web Setup Wizard 401 Unauthorised Access

I had same problem, using Chrome, on FF it worked find.

Re: Web Setup Wizard 401 Unauthorised Access

Solution for me was:
Base URLs (Secure)
-> Use Secure URLs on Storefront -> Yes
-> Use Secure URLs in Admin -> Yes
-> Enable HTTP Strict Transport Security (HSTS) -> Yes
-> Upgrade Insecure Requests -> Yes
php bin/magento cache:clean
https://yadi.sk/i/iPJi4k7X3S86Za
I SOLVE THIS.

Re: Web Setup Wizard 401 Unauthorised Access

this worked for me also. 

i changed from 

Base URLs (Secure)
-> Use Secure URLs on Storefront -> Yes
-> Use Secure URLs in Admin -> Yes
-> Enable HTTP Strict Transport Security (HSTS) -> No
-> Upgrade Insecure Requests -> No 

 

 to

 

Base URLs (Secure)
-> Use Secure URLs on Storefront -> Yes
-> Use Secure URLs in Admin -> Yes
-> Enable HTTP Strict Transport Security (HSTS) -> Yes
-> Upgrade Insecure Requests -> Yes

 

Flush Magento Cache & Flush Cache Storage from Admin.
reload Web Setup Wizard. Fixed