cancel
Showing results for 
Search instead for 
Did you mean: 

Web Setup Wizard

Web Setup Wizard

Hello

can anyone tell me why the web setup wizard is not working, I get this page isn't working 500 error. This is the only thing that isn't working on my site. 

5 REPLIES

Re: Web Setup Wizard

Hi @bigd46

 

Well as you mention that you are facing 500 internal server error - so first we exactly needs to identify whats the error is there !

 

do one thing - from your magento 2 root directory/app/bootstrap.php file

 

open bootstrap.php file - and uncomment the below line by removing # : 

 

ini_set('display_errors', 1);

 

then it will display the error on the browser , post that error so its help us to troubleshoot the issue !

 

Hope it helps

if issue solved,Click Kudos & Accept as Solution

Re: Web Setup Wizard

Fatal error: Uncaught Exception: Warning: ini_set(): Cannot find save handler 'redis' in /home/magento/vendor/magento/framework/Session/SessionManager.php on line 563 in /home/magento/vendor/magento/framework/App/ErrorHandler.php:61 Stack trace: #0 [internal function]: Magento\Framework\App\ErrorHandler->handler(2, 'ini_set(): Cann...', '/home/magento/v...', 563, Array) #1 /home/magento/vendor/magento/framework/Session/SessionManager.php(563): ini_set('session.save_ha...', 'redis') #2

Here is what I found something about redis. It works in the site.

/home/magento/vendor/magento/framework/Session/SessionManager.php(184): Magento\Framework\Session\SessionManager->initIniOptions() #3 /home/magento/generated/code/Magento/Backend/Model/Auth/Session/Interceptor.php(37): Magento\Framework\Session\SessionManager->start() #4 /home/magento/vendor/magento/framework/Session/SessionManager.php(130): Magento\Backend\Model\Auth\Session\Interceptor->start() #5 /home/magento/vendor/magento/module-backend/Model/Auth/Session.php(100): Magento\Framework\Session\SessionManager->__construct(Object(Magento\Fr in /home/magento/vendor/magento/framework/App/ErrorHandler.php on line 61

Re: Web Setup Wizard

Hi @bigd46

 

Seems like you have Redis Cache issue on your server , so its mainly not related to Magento but its related to Redis Cache using Server as well !

 

This is known issue and also reported on Github as well . below i am sharing the links for the same !

 

https://github.com/magento/magento2/issues/15116

 

https://github.com/magento/magento2/issues/2256

 

Hope it helps !

if issue solved,Click Kudos & Accept as Solution

Re: Web Setup Wizard

No I figured it out, you need the php-redis and configure seesion-save-handler

Re: Web Setup Wizard

Hi @bigd46

 

Yes , That's what mention on the Github links which i have shared above as a solution !

 

So That will resolve the issue for the same , if you think the answer is helpful then marked as accept as solution 

 

Hope it helps 

if issue solved,Click Kudos & Accept as Solution