cancel
Showing results for 
Search instead for 
Did you mean: 

Weird email subject

Weird email subject

I'm getting a strange email behaviour when registering an account and the confirmation mail is send out.

 

The subject in the mail shows something like that:

{{{{{trans "Welcome to %store_name." store_name=$store.getFrontendName()}}}}{{{{trans "Welcome to %store_name." store_name=$store.getFrontendName()}}}}{{{{trans "Welcome to %store_name." store_name=$store.getFrontendName()}}}}{{theme6}}}

 

The same behaviour i get inside the mail. The welcome message reads like this:

{{{Willkommen bei XXX.}}{{Willkommen bei %store_name.}}{{Welcome to %store_name.}}{{theme6}}}

 

The mail preview looks alright. But not the mails which are send out. Thats generally for all mails sent. Not only the register mail.

 

I didn't find anything like this via google or in the forum.

 

EDIT: It worked and the only 2 things i can remember that i changed in the meantime was the Mailheader-Logo and i tried to set the shop code from default to german and back.

 

EDIT2: After some more testing i believe this only troubles the mails send from "frontend".

For example: register, password reset... If i send an invoice mail everything seems fine.

If i use a plain mailtemplate like subject:"test" and content:"test" i get:{{{test}}{{test}}{{test}}{{theme6}}}

 

 

Hope someone can help me.

 

Greetz

David

3 REPLIES

Re: Weird email subject

@Davinger0815,

 

You need to change your subject like below way,

{{trans "Welcome to %store_name." store_name=$store.getFrontendName()}}

In your post you have subject with four times curly braces so remove four times to two times and save your temptate.

 

please let me know if you have query.

 

if issue solved, Click kudos/Accept as solutions.

If Issue Solved, Click Kudos/Accept As solutions.

Re: Weird email subject

Hi Rakesh,

 

my Mail-Template just states this in the Subjectline:

{{trans "Welcome to %store_name." store_name=$store.getFrontendName()}}

 

Just one time.

The preview of the template just looks fine.

But the mail send is printing the subject so many times.

 

Im using the standard templates.

Re: Weird email subject

Solved it.

 

The problem was the inline-translation.

Didn't know it effects the mails.