cancel
Showing results for 
Search instead for 
Did you mean: 

cms block and pages not show up in admin

cms block and pages not show up in admin

All in sudden, whitout any action (no extension installation, or configuration set up), i cannot acces anymore my cms block or pages. Everything worked fine when i went to sleep, and horror story this morning.

In fact, the only action i did, was to set up a maintenance page, function provided by my host.

Of course, i removed that function even if i don't believe in a connection here.

I also start googling like crazy, and saw more questions than answers.

The circle is just spinning, don't load anything. Then he stop. So i was thinking about a memory issue. But after reading a lot, nobody talk about that.

If someone could point me in the right direction

(magento 2, vps server)

 

(thanks for reading)

dummes

Tags (2)
7 REPLIES

Re: cms block and pages not show up in admin

Hi @dummes,

 

Can yo ucheck the Magento's logs (system, exception and debug) and also take a look to your webserver error log?

Maybe you can check on your browser console if there are some 404 or 500 error?

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: cms block and pages not show up in admin

Thank you for your answer.
I went to check the 3 magento logs. Not very useful to me. I also activated the error reporting . I didn't notice any difference. Maybe because my store is still in default mode. Should i switch to developer mode ? Would this be useful ? What the difference for the logs. It seems that the error.log is available only in that case.


To what the margento experts would be aware off, in a case like this ?

 

Re: cms block and pages not show up in admin

On your development environment you should use developer mode (for sure).

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: cms block and pages not show up in admin

I activated the developer mode. Enabled also the display_errors. Things went worst. Finally, to keep it short, design was broken and admin completely useless. And the only error description i saw, was : Exception printing is disabled by default for security reasons.

I did a complete restoration with a webhost daily backup from the day BEFORE the disaster. Guess what. The store came back... but with the same errors in the admin (no cms function and also no access to product/customer managment). Yes, at the time from the backup, the store worked well.

What can explain a thing like this ? I feel like in outerspace.

Re: cms block and pages not show up in admin

Hi @dummes,

 

If things went worse after you change the mode is probably you're getting some issues/errors.

The idea of Developer Mode on development or maybe testing servers is to find and prevent those issues on Production.

If you changed back the mode (or restored a backup) and now is working, you'll find (probably) this issues in the future too.

(On live stores you should set the Magento mode to production)

If you like you can take a look here to know more about Magento modes:

 

I'm still thinking you're having issues that the default mode is not showing and the developer mode can't handle without broke the store.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: cms block and pages not show up in admin

Finally got the (half) solution.

The issue was not linked to magento, but to the hosting. And especially to the pageseed module from google (thank you google) who brooke the admin (cms pages and blocks but also customer, sales, etc).

This can explain why i could'nt find useful error reporting in magento itself.

But half solved only, because when i switch to developer mode, i can still not switch back to production mode without breaking the store design (and maybe more)...

 

Thank you Damian for your reply. It's was instructive.

Thank you for reading

Re: cms block and pages not show up in admin

Thank you @dummes for share the resolution!

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"