cancel
Showing results for 
Search instead for 
Did you mean: 

.csv Import: How to escape commas in additional_attributes?

.csv Import: How to escape commas in additional_attributes?

I am importing products via .csv import.  I have an additional_attribute field that contains commas.  Commas are the delimiter within additional_attributes, and when i try to import my products, all of the additional attribute fields that contains commas get cut off after the first comma.  How can i prevent this?

 

I defaulted to adding a product with a comma in the additional attribute field through the admin and exported it.  It looked normal, as shown below at "the battlefield, draw".  But if i try to import that same .csv file the text will be cut off after "battlefield"

I tried a forward slash(backslash?) to no avail. I even surrounded the text in double-quotes for the import... no dice...

 

color=White,magic_card_number=125,magic_cmc=4,magic_expansion=Alliances,magic_flavor_text=<p>coming soon</p>,magic_power=1,magic_rarity=Common,magic_rules_text=<p>Flying</p>
<p>When Carrier Pigeons enters the battlefield, draw a card at the beginning of the next turn's upkeep.</p>,magic_toughness=1,magic_type=Creature,manufacturer=Wizards of the Coast

 

Didn't want to double-post, but i really need help with this... anyone?

Tags (2)
3 REPLIES

Re: .csv Import: How to escape commas in additional_attributes?

 

Didn't want to double-post, but i really need help with this... anyone?

Re: .csv Import: How to escape commas in additional_attributes?

Hi,

 

I too faced the same problem. Did you get any solution for this?

 

Regards,

Abdul

Re: .csv Import: How to escape commas in additional_attributes?

You can use quotes and enable Fields Enclosure option

For example (" bold) here are commas in one field:

<pre>

... ,"gibrid=""F1"",grunt=""З"",latin_name=""Cucumis sativus,"",naznachenie_upotreblenia=""С,К"",opylenietype=""С"",plod_dlinna=""10-12"",plod_massa=""85-110"",posadkatime=""апрель"",skolkoletnee=""О"",sozrevanie=""СК""",1.0000,0.0000,1,0,0,1,1.0000,0,0.0000,1,1,,1,0,1,1,0.0000,1,0,0,0,,,,,,,/h/t/httprostokvill.rupubmediaimportklm10006_b.jpg,Примадонна,,,,,,,,,,,

</pre>