Showing results for 
Search instead for 
Did you mean: 

localhost/magento2/setup page error

localhost/magento2/setup page error

When i want to go to that url,

i get


You don't have permission to access /magento2/setup on this server.
Apache/2.4.18 (Ubuntu) Server at localhost Port 80

i added this

<Directory /var/www/html/magento2>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted

to the

sudo gedit /etc/apache2/apache2.conf 

this is diirectory

sudo ls /var/www/html/magento2/
app      COPYING.txt          LICENSE_AFL.txt      pub
bin      dev              LICENSE.txt      setup     Gruntfile.js.sample  nginx.conf.sample    update
composer.json    index.php        package.json.sample  var
composer.lock    php.ini.sample       vendor  lib              phpserver

i tried a lot of things

this is php

php -v
PHP (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache, Copyright (c) 1999-2016, by Zend Technologies

this is mysql

root@vegan:/var/www/html/magento2# mysql -p
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 465
Server version: 5.7.13-0ubuntu0.16.04.2 (Ubuntu)

Copyright (c) 2000, 2016, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.


this is apache2

root@vegan:/var/www/html/magento2# apache2 -v
Server version: Apache/2.4.18 (Ubuntu)
Server built:   2016-07-14T12:32:26

there seems no errors with those.

when i go to


i got error.

i changed to

<Directory /var/www/html/magento2>
    Options Indexes FollowSymLinks
    AllowOverride all
    Require all granted

but nothing changed, extra line added to the error.

i also changed permissions described here

and here

Make files and directories writable:

To make files and directories writable so you can update components and upgrade the Magento software:

Log in to your Magento server.
Change to your Magento installation directory.
Enter the following commands:

chmod -R u+w .

but now i get only pag with php code despite localhost shows true page:

for http://localhost/magento2/setup/

 * Copyright © 2016 Magento. All rights reserved.
 * See COPYING.txt for license details.

if (PHP_SAPI == 'cli') {
    echo "You cannot run this from the command line." . PHP_EOL .
        "Run \"php bin/magento\" instead." . PHP_EOL;
try {
    require __DIR__ . '/../app/bootstrap.php';
} catch (\Exception $e) {
    echo <<<HTML
<div style="font:12px/1.35em arial, helvetica, sans-serif;">
    <div style="margin:0 0 25px 0; border-bottom:1px solid #ccc;">
        <h3 style="margin:0;font-size:1.7em;font-weight:normal;text-transform:none;text-align:left;color:#2f2f2f;">
        Autoload error</h3>

// For Setup Wizard we are using our customized error handler
$handler = new \Magento\Framework\App\ErrorHandler();
set_error_handler([$handler, 'handler']);

\Zend\Mvc\Application::init(require __DIR__ . '/config/application.config.php')->run();

what can be reason?