cancel
Showing results for 
Search instead for 
Did you mean: 

2.1.2 upgrade issue

2.1.2 upgrade issue

Hello there,

I was trying to Upgrade from Magento 2.1.0 to Magento 2.1.2 through the System Upgrade, I'm using PHP7.0.7, and I got this error:


Parse error: syntax error, unexpected '.' in /home/portugue/public_html/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php on line 93

 

After using a backup to restore the site I tried the upgrade using the command line and I got the same error.

I followed the guide steps: http://devdocs.magento.com/guides/v2.1/comp-mgr/cli/cli-upgrade.html

And I even deleted 

/var/cache 
/var/page_cache 
/var/generation


Can you please help me on that?
Thanks

2 REPLIES

Re: 2.1.2 upgrade issue

I see that there is not only you have this problem in Upgrading Magento 2.1.x , you can submit your error with version at https://github.com/magento/data-migration-tool/issues/64. If you need to upgrade data quick, you should look for other magento upgrade solution.

Re: 2.1.2 upgrade issue

Thanks for the suggestion! I've just done it!