cancel
Showing results for 
Search instead for 
Did you mean: 

2.1.6 -> 2.1.7 Upgrade Fails Readiness Check -- Solved

2.1.6 -> 2.1.7 Upgrade Fails Readiness Check -- Solved

Hi,

  I'm running PHP ver 7.0.18, Apache 2.4.18 on Ubuntu 16.04.2 LTS. 

 

  I'm trying to upgrade from Magento 2.1.6 to 2.1.7 via the System->Web Setup Wizard->System Upgrade page. When I try it fails the readiness check for the following items:

  • Check Cron Scripts
  • PHP Version
  • PHP Settings Check
  • PHP Extensions Check

  Since I've been running 2.1.6 without issue these results are seemingly incorrect. I encountered the same issue when installing 2.1.6 but was able to resolve them by editing the /composer.json file by adding this "disable-tls" line below. This resolved an open_basedir warning for "/etc/pki/tls/certs".

 

"config": {
        "use-include-path": true,
	"disable-tls": true
    }

 

 

  Any ideas how to resolve this?

 

Thanks,

Renée

 

 

2 REPLIES

Re: 2.1.6 -> 2.1.7 Upgrade Fails Readiness Check -- Solved

This problem has been solved. Setting up cron, as described in the link below, resolved the problem. 

 

Thanks,

Renée

Re: 2.1.6 -> 2.1.7 Upgrade Fails Readiness Check -- Solved

1. Login into your Magento 2 Server with SSH

2. Navigate to the Magento 2 installation directory

3. Run this

composer require magento/product-community-edition 2.1.7 --no-update
4. Run composer update command

composer update
5. Delete all generated di, view processes and cache files

rm -rf var/*
6. When composer update has been finished, upgrade your database by running the Magento 2 CLI command:

php bin/magento setup:upgrade
7. Flush magento cache

php bin/magento cache:flush
8. Deploy static files

php bin/magento setup:static-content:deploy
9. Generate Dependency Injection (DI) files

php bin/magento setup:di:compile
10. Run indexers

php bin/magento indexer:reindex
11. Verify the Magento 2 version upgrade

When you run the Magento 2 CLI you see the new version in the first line

php bin/magento