cancel
Showing results for 
Search instead for 
Did you mean: 

2.2.4 to 2.4.1 Upgrade failed

2.2.4 to 2.4.1 Upgrade failed

Hi,

 

I followed this topic to upgrade Magento 2.2.4 to 2.4.1 community edition, i don't think may be i was wrong, the topic is talking about enterprise edition but i have community edition.

I runned those commands

 

composer require magento/composer-root-update-plugin=~1.0 --no-update
composer update --ignore-platform-reqs
cp composer.json composer.json.bak
composer remove magento/product-community-edition --no-update
composer require magento/product-community-edition 2.4.1 --no-update
composer update --ignore-platform-reqs

I got this error

[InvalidArgumentException]                                           
  Package is not installed: magento/project-community-edition-2.4.1.0  

In composer.json i've already changed version from 2.2.1 to 2.4.1

   "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.4.1",

I changed it since i have those errors with 2.2.1

Problem 1
    - magento/project-community-edition 2.2.1 requires magento/product-community-edition 2.2.1 -> satisfiable by magento/product-community-edition[2.2.1] but these conflict with your requirements or minimum-stability.
    - Installation request for magento/product-community-edition 2.4.1 -> satisfiable by magento/product-community-edition[2.4.1].
    - temando/module-shipping 2.0.0 requires temando/module-shipping-remover 1.0.0 -> satisfiable by temando/module-shipping-remover[1.0.0].
    - don't install temando/module-shipping-remover 1.0.0|remove magento/project-community-edition 2.2.1
    - magento/product-community-edition 2.4.1 requires temando/module-shipping 2.0.0 -> satisfiable by temando/module-shipping[2.0.0].
    - Installation request for magento/project-community-edition 2.2.1 -> satisfiable by magento/project-community-edition[2.2.1].

Another isssue in vendor folder i found zendframework folder is empty.

 

If anyone have an idea, i will be grateful.

 

 

3 REPLIES 3

Re: 2.2.4 to 2.4.1 Upgrade failed

@tarek_fellah 

Find the below line in your composer.json file:
magento/product-community-edition
modify as:
 
"magento/product-community-edition": "2.4.2",
and execute composer update ignore-platform-reqs
 
make sure your system requirements satisfied with following:
 
Problem solved? Click Kudos and "Accept as Solution"

Re: 2.2.4 to 2.4.1 Upgrade failed

Hello @tarek_fellah ,

 

You can try this solution to upgrade Magento 2.3.5-p1 to Magento 2.4, there are few changes that you need to do in your composer.json
Run the below command step by step to upgrade Magento 2.3.5 to Magento 2.4:
1) cp composer.json composer.json.bak (this command create backup of composer.json)
2) composer require magento/product-community-edition=2.4.0 --no-update
3) Now open composer.json file and do following required changes in version manually:
(a) "friendsofphp/php-cs-fixer": "~2.16.0"
(b) "magento/magento2-functional-testing-framework": "^3.0"
(c) "pdepend/pdepend": "~2.7.1"
(d) "phpmd/phpmd": "^2.8.0"
(e) "phpstan/phpstan": ">=0.12.3 <=0.12.23"
(f) "phpunit/phpunit": "^9"
(g) "sebastian/phpcpd": "~5.0.0"
(h) "squizlabs/php_codesniffer": "~3.5.4"
(4) Last and final step run following command:
composer update
After completing this command, you have to run the Magento setup upgrade, di compile, deploy command also.

 

If still having the issue contact us. If this will work then Accept it as a solution.

Click Kudos.

Thank you..!!

 

Re: 2.2.4 to 2.4.1 Upgrade failed

I updated composer.json file as follows

 

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.2.1",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "magento/product-community-edition": "2.4.0",
        "composer/composer": "@alpha",
        "cart2quote/module-autoproposal": "^1.0",
        "zendframework/zend-mail": "^2.10",
        "mageplaza/magento-2-french-language-pack": "dev-master",
        "imaginaerum/magento2-language-fr-fr": "*",
        "mageplaza/module-google-recaptcha": "^1.0",
        "fooman/emailattachments-m2": "^3.0",
        "fooman/printorderpdf-m2": "^3.1",
        "symfony/yaml": "dev-issue-8145",
        "fooman/sameorderinvoicenumber-m2": "^3.0",
        "kiwicommerce/module-admin-activity": "^1.0",
        "guzzlehttp/guzzle": "^6.5",
        "ebizmarts/mailchimp-lib": "^3.0",
        "magento/composer-root-update-plugin": "~1.0",
        "symfony/console": "4.4.26"
    },
    "require-dev": {
        "phpunit/phpunit": "~6.2.0",
        "squizlabs/php_codesniffer": "3.2.2",
        "phpmd/phpmd": "@stable",
        "pdepend/pdepend": "2.5.2",
        "friendsofphp/php-cs-fixer": "2.19.0",
        "lusitanian/oauth": "~0.8.10",
        "sebastian/phpcpd": "~3.0.0"
    },
    "replace": {
        "dotmailer/dotmailer-magento2-extension": "*",
        "dotmailer/dotmailer-magento2-extension-package": "*",
        "dotmailer/dotmailer-magento2-extension-enterprise": "*",
        "dotmailer/dotmailer-magento2-extension-chat": "*",
        "amzn/amazon-pay-and-login-magento-2-module": "*",
        "klarna/module-core": "*",
        "klarna/module-kp": "*",
        "klarna/module-ordermanagement": "*",
        "shopialfb/facebook-module": "*",
        "magento/module-signifyd": "*"
    },
    
    "autoload": {

        "psr-4": {

            "Magento\\Framework\\": "lib/internal/Magento/Framework/",

            "Magento\\Setup\\": "setup/src/Magento/Setup/",

            "Magento\\": "app/code/Magento/",

            "Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/"

        },
        "psr-0": {
            "": [
                "app/code/"
            ]
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ],
        "exclude-from-classmap": [
            "**/dev/**",
            "**/update/**",
            "**/Test/**"
        ]
    },
    "autoload-dev": {

        "psr-4": {

            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",

            "Magento\\Tools\\": "dev/tools/Magento/Tools/",

            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",

            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",

            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
            
        }
    },
    "minimum-stability": "stable",
    "repositories": {
        "0": {
            "type": "composer",
            "url": "https://repo.magento.com/"
        },
        "foomanartifacts": {
            "type": "artifact",
            "url": "/home/wetag/public_html/vendor/fooman/packages"
        }
    },
    "extra": {
        "magento-force": "override"
    }
}

composer update --ignore-platform-reqs

php -dmemory_limit=-1 bin/magento setup:upgrade
php -dmemory_limit=1G bin/magento setup:di:compile

 

And i disabled third party module that are not compatible with Magento 2.4.0