cancel
Showing results for 
Search instead for 
Did you mean: 

2.3.5-P1 to 2.4.0 upgrade Fails

SOLVED
Highlighted

2.3.5-P1 to 2.4.0 upgrade Fails

2.3.5-P1 to 2.4.0 Upgrade fails

 

I have a Clone of my website to test the Upgrade to the latest version.

Unfortunately I am running into issues.

 

Steps to reproduce:

composer require magento/composer-root-update-plugin=~1.0 --no-update

composer update

cp composer.json composer.json.bak

composer remove magento/product-community-edition --no-update

composer require magento/product-community-edition=2.4.0 --no-update

composer update

Outcome:

 

Your requirements could not be resolved to an installable set of packages.

 

Problem 1
- magento/magento2-functional-testing-framework 2.5.3 requires codeception/codeception ~2.3.4 || ~2.4.0 -> satisfiable by codeception/codeception[2.4.5, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4].
- magento/magento2-functional-testing-framework 2.5.3 requires codeception/codeception ~2.3.4 || ~2.4.0 -> satisfiable by codeception/codeception[2.4.5, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.3.9, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4].
- codeception/codeception 2.4.0 requires codeception/phpunit-wrapper ^6.0|^7.0 -> satisfiable by codeception/phpunit-wrapper[6.8.1, 6.0.0, 6.0.1, 6.0.10, 6.0.11, 6.0.12, 6.0.13, 6.0.14, 6.0.15, 6.0.16, 6.0.17, 6.0.18, 6.0.19, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.0.9, 6.1.0, 6.1.1, 6.1.2, 6.1.3, 6.5.0, 6.5.1, 6.6.0, 6.6.1, 6.7.0, 6.7.1, 6.8.0, 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.0.5, 7.0.6, 7.1.0, 7.1.1, 7.1.2, 7.1.3, 7.1.4, 7.2.0, 7.3.0, 7.3.1, 7.3.2, 7.4.0, 7.5.0, 7.6.0, 7.6.1, 7.7.0, 7.7.1, 7.7.2, 7.8.0].
- codeception/codeception 2.4.1 requires codeception/phpunit-wrapper ^6.0.9|^7.0.6 -> satisfiable by codeception/phpunit-wrapper[6.8.1, 6.0.10, 6.0.11, 6.0.12, 6.0.13, 6.0.14, 6.0.15, 6.0.16, 6.0.17, 6.0.18, 6.0.19, 6.0.9, 6.1.0, 6.1.1, 6.1.2, 6.1.3, 6.5.0, 6.5.1, 6.6.0, 6.6.1, 6.7.0, 6.7.1, 6.8.0, 7.0.6, 7.1.0, 7.1.1, 7.1.2, 7.1.3, 7.1.4, 7.2.0, 7.3.0, 7.3.1, 7.3.2, 7.4.0, 7.5.0, 7.6.0, 7.6.1, 7.7.0, 7.7.1, 7.7.2, 7.8.0].

 

These are the lines in my composer.json

"magento/magento2-functional-testing-framework": "2.5.3",

"phpunit/phpunit": "~6.5.0",

 

Anny one a suggestion how to resolve this?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: 2.3.5-P1 to 2.4.0 upgrade Fails

First set correct php version 7.3.x or7.4.x

Warning if your test environment with an older php version is on the same server You live site can get down due to PHP version compatibility.

 

Second

Update Composer to latest version before any other action!!!

Commands:

 

1. composer self-update

2. composer update

 

After this run:

composer require magento/composer-root-update-plugin=~1.0 --no-update

composer update

cp composer.json composer.json.bak

composer remove magento/product-community-edition --no-update

composer require magento/product-community-edition=2.4.0 --no-update

composer update

 

This was working for me

View solution in original post

5 REPLIES 5
Highlighted

Re: 2.3.5-P1 to 2.4.0 upgrade Fails

First set correct php version 7.3.x or7.4.x

Warning if your test environment with an older php version is on the same server You live site can get down due to PHP version compatibility.

 

Second

Update Composer to latest version before any other action!!!

Commands:

 

1. composer self-update

2. composer update

 

After this run:

composer require magento/composer-root-update-plugin=~1.0 --no-update

composer update

cp composer.json composer.json.bak

composer remove magento/product-community-edition --no-update

composer require magento/product-community-edition=2.4.0 --no-update

composer update

 

This was working for me

View solution in original post

Highlighted

Re: 2.3.5-P1 to 2.4.0 upgrade Fails

Isn't working for us:

 

magento/framework 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.13 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.14 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.15 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.16 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.17 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.18 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.19 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.0.20 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.13 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.14 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.16 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.17 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 100.1.18 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.1 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.2 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.3 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.5 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.6 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.7 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.8 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.9 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.10 requires php ~7.0.13|~7.1.0|~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 101.0.11 requires php ~7.0.13||~7.1.0||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 102.0.0 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 102.0.1 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 102.0.2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.
    - magento/framework 102.0.2-p2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.20) does not satisfy that requirement.

We tried your reply and magento dev docs also...No luck

 

Any suggestions please?

Highlighted

Re: 2.3.5-P1 to 2.4.0 upgrade Fails

Best,

 

1. Run : composer self-update

2. clean cache: php bin/magento cache:clean

3. Try upgrade again.

 

If not working try: php bin/magento cache:flush and try again.
I Hope it helps you

 

Highlighted

2.3.5-P1 to 2.4.0 upgrade successfully

We have upgraded magento 2.3.5-p1 to Magento 2.4 using following link.

 

Please refer it: https://itcruncher.blogspot.com/2020/09/upgrade-magento-2.3.5-p1-to-magento-2.4.html

Highlighted

Re: 2.3.5-P1 to 2.4.0 upgrade successfully

Thank you, this did the job