cancel
Showing results for 
Search instead for 
Did you mean: 

2.3.5 to 2.4 Upgrade Fails With Composer

Highlighted

2.3.5 to 2.4 Upgrade Fails With Composer

Hi there,

 

I am upgrading Magento version 2.3.5 to 2.4.0 and composer is failing with the following Problem. 

 

Any ideas?

------

Your requirements could not be resolved to an installable set of packages.

 

  Problem 1

    - magento/security-package 1.0.0 requires magento/module-two-factor-auth 1.0.0 -> satisfiable by magento/module-two-factor-auth[1.0.0].

    - magento/product-community-edition 2.4.0 requires magento/security-package 1.0.0 -> satisfiable by magento/security-package[1.0.0].

    - Installation request for magento/product-community-edition 2.4.0 -> satisfiable by magento/product-community-edition[2.4.0].

    - msp/twofactorauth 3.1.2 requires spomky-labs/otphp ~8.3 -> satisfiable by spomky-labs/otphp[v8.3.3, v8.3.0, v8.3.1, v8.3.2].

    - msp/twofactorauth 3.1.2 requires spomky-labs/otphp ~8.3 -> satisfiable by spomky-labs/otphp[v8.3.3, v8.3.0, v8.3.1, v8.3.2].

    - Can only install one of: spomky-labs/otphp[v8.3.0, v10.0.0].

    - Can only install one of: spomky-labs/otphp[v8.3.1, v10.0.0].

    - Can only install one of: spomky-labs/otphp[v8.3.2, v10.0.0].

    - Can only install one of: spomky-labs/otphp[v8.3.3, v10.0.0].

    - Can only install one of: spomky-labs/otphp[v10.0.0, v8.3.3].

    - magento/module-two-factor-auth 1.0.0 requires spomky-labs/otphp ^10.0 -> satisfiable by spomky-labs/otphp[v10.0.0, v10.0.1].

    - Conclusion: don't install spomky-labs/otphp v10.0.1

    - Installation request for msp/twofactorauth 3.1.2 -> satisfiable by msp/twofactorauth[3.1.2].

 

Any help would be much appreciated, cheers Darren

1 REPLY 1
Highlighted

Re: 2.3.5 to 2.4 Upgrade Fails With Composer

Are you using Porto theme?

 

Also, did you ever get this fixed?