cancel
Showing results for 
Search instead for 
Did you mean: 

Awkward Magento 2.1.3 to 2.1.13 upgrade error

Awkward Magento 2.1.3 to 2.1.13 upgrade error

Hello,

I've tried to update my store from 2.1.3 to 2.1.13. I did it on deployment server with success following those steps:

composer require magento/product-community-edition 2.1.13 --no-update
composer update
rm -rf var/*
php bin/magento setup:upgrade
php bin/magento cache:flush
php bin/magento setup:static-content:deploy
php bin/magento setup:di:compile
php bin/magento indexer:reindex
chown -R apache:apache /var/www/html/
php bin/magento cache:flush

When I did exactly the same thing on production,  after the last step ( flushing cache ) almost all my files from magento root folder were deleted. 

I've restored my server from last snapshot right away, so I don't have any logs.

I did it twice, same thing happened every time.


Any idea what this could be?

2 REPLIES

Re: Awkward Magento 2.1.3 to 2.1.13 upgrade error

Hi @jalnet

 

there should be a two reasons , on your production setup , check which magento environment it is in there ? - is it in production ?

 

If yes kindly change it into developer mode by running this command - php bin/magento deploy:mode:show developer and then try to upgrade.

 

second and most important thing is ownership and permission , its depends which user are you using to upgrade the version ? if should be with magento user.

 

so refer this link for permission and ownership issue - https://devdocs.magento.com/guides/v2.1/comp-mgr/cli/cli-rc1-samp.html

 

if issue solved,Click Kudos & Accept as Solution

Re: Awkward Magento 2.1.3 to 2.1.13 upgrade error

Hi @jalnet

 

Not sure , but you make check composer update deleted all files in mage2 folder once.

---
Problem Solved Click Accept as Solution!:Magento Community India Forum