cancel
Showing results for 
Search instead for 
Did you mean: 

Can't open Front or Back End of my site

SOLVED

Can't open Front or Back End of my site

When I try to open my front end I get an errors

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory.
The following modules are outdated:
Magento_Tax data: current version - 2.0.2, required version - 2.0.3
Magento_CatalogAnalytics data: current version - none, required version - 2.0.0
Dotdigitalgroup_Email data: current version - none, required version - 2.3.8
Magento_WishlistAnalytics data: current version - none, required version - 2.0.0
Temando_Shipping data: current version - none, required version - 0.3.1

Exception #0 (Magento\Framework\Exception\LocalizedException): Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory.
The following modules are outdated:
Magento_Tax data: current version - 2.0.2, required version - 2.0.3
Magento_CatalogAnalytics data: current version - none, required version - 2.0.0
Dotdigitalgroup_Email data: current version - none, required version - 2.3.8
Magento_WishlistAnalytics data: current version - none, required version - 2.0.0
Temando_Shipping data: current version - none, required version - 0.3.1
#0 /home/jewelrynest2/public_html/magento/vendor/magento/framework/Interception/Interceptor.php(121): Magento\Framework\Module\Plugin\DbStatusValidator->beforeDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Magento\Framework\App\Request\Http))
#1 /home/jewelrynest2/public_html/magento/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#2 /home/jewelrynest2/public_html/magento/generated/code/Magento/Framework/App/FrontController/Interceptor.php(26): Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', Array, Array)
#3 /home/jewelrynest2/public_html/magento/vendor/magento/framework/App/Http.php(135): Magento\Framework\App\FrontController\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#4 /home/jewelrynest2/public_html/magento/generated/code/Magento/Framework/App/Http/Interceptor.php(24): Magento\Framework\App\Http->launch()
#5 /home/jewelrynest2/public_html/magento/vendor/magento/framework/App/Bootstrap.php(256): Magento\Framework\App\Http\Interceptor->launch()
#6 /home/jewelrynest2/public_html/magento/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http\Interceptor))
#7 {main}

I am new to Magento, please help if you can direct me how to do it 

 

JewelryNest
Tags (3)
7 REPLIES

Re: Can't open Front or Back End of my site

This is localized exception error along with module version upgrade error.

 

So open your terminal from your root directory of magento2 and run below commands in sequence.

 

 

1) php bin/magento setup:upgrade
2) php bin/magento setup:di:compile
3) php bin/magento setup:static-content:deploy
4) php bin/magento indexer:reindex
5) php bin/magento cache:clean
6) php bin/magento cache:flush

 

 

if issue solved,Click Kudos & Accept as Solution

Re: Can't open Front or Back End of my site

Thank you for the reply I wish that i can do it  from where to start any direction

 

JewelryNest

Re: Can't open Front or Back End of my site

Yes , if you follow above all the instructions . you will definitely solve your issue.

if issue solved,Click Kudos & Accept as Solution

Re: Can't open Front or Back End of my site

how long will take and if I loos any data

JewelryNest

Re: Can't open Front or Back End of my site

No !! you will not loose any data !! 

 

and its very few mins work , you just need to run commands only !!

if issue solved,Click Kudos & Accept as Solution

Re: Can't open Front or Back End of my site

Thank you,  you can contact me by tomorrow night

JewelryNest

Re: Can't open Front or Back End of my site

I run a command but its seem that the theme cannot be down load and shows an error

JewelryNest