cancel
Showing results for 
Search instead for 
Did you mean: 

Composer unable to upgrade from 2.3.5-p1 to 2.4.0

Highlighted

Composer unable to upgrade from 2.3.5-p1 to 2.4.0

For some reason I can't even get composer to understand that there are new versions of Magento.

 

$ composer require magento/product-enterprise-edition=2.4.0 --no-update
Could not find a Magento project package matching "magento/product-enterprise-edition 2.4.0" for PHP version 7.3.11

Update of composer.json with Magento Commerce 2.4.0 changes failed, reverting ./composer.json to its original content from before the Magento root update.
Magento root updates cannot run without a valid target package


  [InvalidArgumentException]
  Could not find a matching version of package magento/product-enterprise-edition. Check the package spelling, your version constraint and that the package is available in a stability which matches your m
  inimum-stability (stable).

I get the same message if I upgrade to php7.4. I'm kind of at a loss right now as we can no longer update our store.

4 REPLIES 4
Highlighted

Re: Composer unable to upgrade from 2.3.5-p1 to 2.4.0

Hello @dustin_metcalf 

 

This is not the correct way to upgrade Magento, please check the below method to upgrade your Magento :

https://www.goivvy.com/blog/magento-2-upgrade

 

Hop it will help.

Problem Solved ? Click on 'Kudos' & Accept as Solution to encourage to write more answers !
Highlighted

Re: Composer unable to upgrade from 2.3.5-p1 to 2.4.0

I was following the instructions outlines here https://devdocs.magento.com/guides/v2.4/comp-mgr/cli/cli-upgrade.html which appear to be the same as the link you provided. Am I to assume I should use step 3 where I just download and extract on top of my local install and hope I don't clobber any of the changes make by my dev team?

Highlighted

Re: Composer unable to upgrade from 2.3.5-p1 to 2.4.0

Highlighted

Re: Composer unable to upgrade from 2.3.5-p1 to 2.4.0

Do you have any issue with the PHP version readiness check?