cancel
Showing results for 
Search instead for 
Did you mean: 

Error upgrading from 2.3.4 to 2.3.4-p2

Error upgrading from 2.3.4 to 2.3.4-p2

I'm trying to update magento 2.3.4. to 2.3.4-p2 but I'm not having any success. When I run composer require the error message is:


- Can only install one of: vertex/product-magento-module[3.3.0, 3.3.1].
- Can only install one of: vertex/product-magento-module[3.3.1, 3.3.0].
- Can only install one of: vertex/product-magento-module[3.3.1, 3.3.0].
- magento/product-community-edition 2.3.4-p2 requires vertex/product-magento-module 3.3.1 -> satisfiable by vertex/product-magento-module[3.3.1
- Installation request for vertex/product-magento-module (locked at 3.3.0) -> satisfiable by vertex/product-magento-module[3.3.0]

I can't upgrade vertex/product-magento-module to 3.3.1 because Magento 2.3.4 requires vertex/product-magento-module 3.3.0

How do I resolve this please?

I have Vertex_Tax and Vertex_AddressValidation modules installed and active.

1 REPLY 1

Re: Error upgrading from 2.3.4 to 2.3.4-p2

I have the same issue with a different extension. 

I did manage to clear a few, but got left with this;

 

Loading composer repositories with package information
In Laminas\DependencyPlugin\DependencyRewriterV2::onPrePoolCreate
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - composer/composer[1.9.0, ..., 1.10.x-dev] require composer/xdebug-handler ^1.1 -> found composer/xdebug-handler[1.1.0, ..., 1.4.x-dev] but it conflicts with your root composer.json require (2.0.2).
    - magento/product-community-edition 2.4.3 requires magento/composer 1.6.0 -> satisfiable by magento/composer[1.6.0].
    - magento/composer 1.6.0 requires composer/composer ^1.9 -> satisfiable by composer/composer[1.9.0, ..., 1.10.x-dev].
    - Root composer.json requires magento/product-community-edition 2.4.3 -> satisfiable by magento/product-community-edition[2.4.3].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

If I change the composer.json file to match the xdebug version it is expecting to see, I go right back to the problem you have.

I'm also stuck...