cancel
Showing results for 
Search instead for 
Did you mean: 

Error while upgrade from Magento 2.3.1 to Magento 2.3.3

Highlighted

Error while upgrade from Magento 2.3.1 to Magento 2.3.3

Hi All,
We are getting the below error while upgrade from Magento 2.3.1 to Magento 2.3.3:

- lib-libsodium is present at version 1.0.18 and cannot be modified by Composer
- You can only install one version of a package, so only one of these can be installed: lib-libsodium[1.0.18]. 

libsodium library version => 1.0.18 not sure why Magento upgrade wants to change the version here ,but other Magento site on the same environment gets upgraded seamlessly.

 

If someone can pls help in this.

 

Thanks in Advance!

 

 

1 REPLY 1
Highlighted

Re: Error while upgrade from Magento 2.3.1 to Magento 2.3.3

Hello @uttamsk89 

 

Add --ignore-platform-reqs at the end of your command.

 

I hope it helps.

 

Problem solved? Click Kudos and "Accept as Solution"