cancel
Showing results for 
Search instead for 
Did you mean: 

Error while upgrading from 2.2.1 to 2.2.2

Error while upgrading from 2.2.1 to 2.2.2

Hi there,

we've got a problem with updating our Magento system from 2.2.1 to 2.2.2.
There is an error that seems to have to do with the dotmailer extension that is integrated in Magento 2.2.2.

We've tried several times, but the same error occurs (see below):

[2018-03-01 14:18:04 UTC] Job "setup:cache:disable []" has been successfully completed
[2018-03-01 14:18:19 UTC] Job "update {"components":[{"name":"magento/product-community-edition","version":"2.2.2"}]}" has been started
[2018-03-01 14:18:19 UTC] Starting composer update...
[2018-03-01 14:18:19 UTC] ./composer.json has been updated

[2018-03-01 14:18:56 UTC] An error occurred while executing job "update {"components":[{"name":"magento/product-community-edition","version":"2.2.2"}]}": Could not complete update {"components":[{"name":"magento/product-community-edition","version":"2.2.2"}]} successfully: Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)


[RuntimeException]
Could not load package dotmailer/dotmailer-magento2-extension in http://packagist.org: [UnexpectedValueException] Could not parse version constraint 100.*.*: Invalid version string "100.*.*"


[UnexpectedValueException]
Could not parse version constraint 100.*.*: Invalid version string "100.*.*"


update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [packages1] ... [packagesN]

 

Can anybody help?

1 REPLY

Re: Error while upgrading from 2.2.1 to 2.2.2

I've moved your topic from the Magento 1 section to the Magento 2 section. 

 

It looks like the issue may be an incompatibility of the dotmailer extension with version 2.2.2. 

 

Have you contacted the extension developer about this? 

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips