cancel
Showing results for 
Search instead for 
Did you mean: 

Facing issue on magento upgrade 2.2.0 To 2.2.1

SOLVED

Facing issue on magento upgrade 2.2.0 To 2.2.1

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for magento/product-community-edition 2.2.1 -> satisfiable by magento/product-community-edition[2.2.1].
    - magento/product-community-edition 2.2.1 requires magento/module-signifyd 100.2.1 -> no matching package found.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Tags (2)
5 REPLIES

Re: Facing issue on magento upgrade 2.2.0 To 2.2.1

This is a confirmed issue with the upgrade at the minute from what I've seen on twitter. Here's a stackoverflow post with an answer quoted from Piotr that there is a caching problem on Magento's side that's preventing the signifyd module update to be available for some people:

 

https://magento.stackexchange.com/questions/200449/magento-2-2-1-possible-upgrade-issues

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: Facing issue on magento upgrade 2.2.0 To 2.2.1

Workaround if you don't need the signifyd module: Add it to your "replace" section in the composer json as follows:

 

"replace": {
        "magento/module-signifyd": "*"
    },


this is the best way to remove unneeded modules. If you don't need that module as well, I'd leave that change in your composer.json. The composer.json is made for modification, your changes can stay. If you need the signifyd module, you should revert the change later of course.

 

Re: Facing issue on magento upgrade 2.2.0 To 2.2.1

The issue of availability of the module has been resolved by Magento. Please check upgrade Magento to version 2.2.1 now.

Re: Facing issue on magento upgrade 2.2.0 To 2.2.1

I am still experiencing the problem 

Re: Facing issue on magento upgrade 2.2.0 To 2.2.1

try to cd to you magento installation folder before running composer. 

i seen the same issue before , and above was the solution .. it may or may not help.