cancel
Showing results for 
Search instead for 
Did you mean: 

Issues using the Code Migration to migrate to Magento CE v2.2.3 w/ PHP 7.1

Issues using the Code Migration to migrate to Magento CE v2.2.3 w/ PHP 7.1

I'm attempting to use the code-migration toolkit provided by Magento to assist in our migration to Magento CE v2.2.3 (from v1.9.3.4), but after I clone the latest branch and execute either composer install or composer update, I get errors stating that the version of PHP I have installed (v7.1.17) isn't supported, and instead lists the PHP version requirements of php ~5.5.0|~5.6.0|~7.0.0. However, according to the requirements listed in the README, any PHP version greater than 5.5x is supported. (Exact output of composer commands pasted at the bottom)

 

I'm somewhat new to Composer, but I notice that the version requirements in the composer.lock for PHP is set as ~5.5.0|~5.6.0|~7.0.0, but the PHP version requirement found in the composer.json file is set as ~5.5.0|~5.6.0|~7.0.0|~7.1.0. Should the composer.lock file reflect the same PHP version requirements as the composer.json?

 

I haven't found too much about this, with the exception of an open issue I found under a separate repository which is pretty similar. As well as another issue where a user encountered a similar issue (unrelated repo), and was able to resolve it by executing composer update --lock. I attempted executing the same command only to have Composer run into 6 more "Problems". Output below.

 

Composer Commands & Output

-bash-4.2$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for magento/framework 100.0.12 -> satisfiable by magento/framework[100.0.12].
    - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.

-bash-4.2$ composer update
Loading composer repositories with package information
Initializing PEAR repository https://pear.php.net
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/framework 100.0.20 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.19 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.18 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.17 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.16 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.15 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.14 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.13 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - Installation request for magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
-bash-4.2$ composer update --lock
Loading composer repositories with package information
Initializing PEAR repository https://pear.php.net
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package zendframework/zend-stdlib (locked at 2.4.0, required as 2.5.0) is satisfiable by zendframework/zend-stdlib[2.4.0] but these conflict with your requirements or minimum-stability.
  Problem 2
    - The requested package zendframework/zend-code (locked at 2.4.0, required as 2.5.0) is satisfiable by zendframework/zend-code[2.4.0] but these conflict with your requirements or minimum-stability.
  Problem 3
    - The requested package zendframework/zend-http (locked at 2.4.0, required as 2.5.0) is satisfiable by zendframework/zend-http[2.4.0] but these conflict with your requirements or minimum-stability.
  Problem 4
    - The requested package sebastian/phpcpd (locked at 2.0.0, required as 2.0.4) is satisfiable by sebastian/phpcpd[2.0.0] but these conflict with your requirements or minimum-stability.
  Problem 5
    - The requested package pdepend/pdepend (locked at 2.0.6, required as 2.5.0) is satisfiable by pdepend/pdepend[2.0.6] but these conflict with your requirements or minimum-stability.
  Problem 6
    - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.20 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.19 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.18 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.17 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.16 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.15 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.14 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.13 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - magento/framework 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.17) does not satisfy that requirement.
    - Installation request for magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].

 Any input would be appreciated. Thanks!

 

P.S. Heres some specifics regarding the software being used:

  • Operating System: CentOS v7.3.1611
  • Web Server: Apache v2.4.6
  • PHP: PHP v7.1.17
  • Database: MySQL  v5.6.40
  • Composer: v1.6.3
3 REPLIES

Re: Issues using the Code Migration to migrate to Magento CE v2.2.3 w/ PHP 7.1

Plz try with below command from SSH with your root permission,

Go TO magento instance where you have installed your magento,

composer update
If Issue Solved, Click Kudos/Accept As solutions.

Re: Issues using the Code Migration to migrate to Magento CE v2.2.3 w/ PHP 7.1

Hello @liberty_distribution

 

Can you please share composer.json code?

Re: Issues using the Code Migration to migrate to Magento CE v2.2.3 w/ PHP 7.1

@Rakesh Jesadiya wrote:

Plz try with below command from SSH with your root permission,

Go TO magento instance where you have installed your magento,

composer update

This is actually for the Magento code-migration tools, not the instance of Magento 2 I have setup - that actually works just fine. I'm now attempting to migrate as much as I can from our Magento 1.9 instance using the code-migration tools, which is where I'm running into the Composer problem.

@Sunil Patel wrote:

Hello @liberty_distribution

 

Can you please share composer.json code?

I checked out the code-migration repository and followed the installation instructions in the README, so the composer.json isn't any different than what's in the repository right now (here).

 

Note: I updated the original post to include the application stack and software versions being used.