cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.0.2 upgrade to 2.0.4 fails at Component Dependency check

Magento 2.0.2 upgrade to 2.0.4 fails at Component Dependency check

I have the CE version of 2.0.2 installed on Ubuntu Server 14.0.4 LTS and it's been working fine. Trying to upgrade to 2.0.4 and it fails the readiness check with:

 

Check Component Dependency
We found conflicting component dependencies. Hide detail

 

For additional assistance, see component dependency help .

 

The problem is, there are no details or further clues that I can find. Is there a log file somewhere that might give more detail than this? I have shell access to the server. Everything else passes.

 

Anyone have any ideas?

2 REPLIES

Re: Magento 2.0.2 upgrade to 2.0.4 fails at Component Dependency check

Following the upgrade guide elsewhere here, I was able to upgrade to 2.0.4 using the shell.

 

I used the following:

 

composer require magento/product-community-edition 2.0.4 --no-update
composer update
rm -rf var/di var/generation
php bin/magento cache:clean
php bin/magento cache:flush
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento indexer:reindex

 

 

Hope this helps someone.

Re: Magento 2.0.2 upgrade to 2.0.4 fails at Component Dependency check

Also saw an upgrade guide somewhere here, with an additional command:

 

composer update magento/magento-composer-installer
composer require magento/product-community-edition 2.0.4 --no-update

...