cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.1.10 to 2.2.5 nothing happened

Magento 2.1.10 to 2.2.5 nothing happened

I tried to update my magento 2.1.10 to 2.2.5 but I think never happened.

I used the following commands.

php bin/magento cache:disable

composer require magento/product-community-edition 2.2.5 --no-update

composer update

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy
php bin/magento cache:clean
php bin/magento cache:flush
php bin/magento indexer:reindex

 

6 REPLIES

Re: Magento 2.1.10 to 2.2.5 nothing happened

Hi @tomzol

 

Are you facing any error ? Meaning any error shows while running this commands ? 

 

Looks like you have done everything correctly , Can you confirm the PHP version are you using is supported with Magento 2.2.5 ? - because that should be the only case where its not upgrading , so you need to upgrade PHP version first !

 

Second things , if directly its not upgrading with 2.2.5 then first upgrade with at least magento 2 version 2.2.0 only  then later on upgrade to 2.2.5

 

Below is the details how to upgrade to 2.2.0

 

php bin/magento maintenance:enable
composer require magento/product-community-edition 2.2.0 --no-update
composer update
rm -rf var/cache/*
rm -rf var/page_cache/*
rm -rf var/generation/*
chmod +x bin/magento
php bin/magento setup:upgrade
php bin/magento maintenance:disable

Then try , it will works for sure !

 

Hope it helps 

if issue solved,Click Kudos & Accept as Solution

Re: Magento 2.1.10 to 2.2.5 nothing happened

Hi Dave,

 

Thank you for your help.
My php version is php 7.0.22

Is it old for 2.2.4 or 2.2.5?

problem.png 

After  php bin/magento setup: upgrade command I get this:

"Please re-run Magento compile command"

I login after as an admin to Magento and I see still 2.1.10 Smiley Sad

Re: Magento 2.1.10 to 2.2.5 nothing happened

Hi @tomzol

 

Well , it looks like your PHP version is compatible with Magento 2.2.4 and 2.2.5.

 

Have you tried which i have given above ? like upgrade to 2.2.0 first and then update to 2.2.5

 

That will surely works for you - also make sure no space or any other thing will be there in the command.

 

Because this is the standard method to upgrade any magento version !

if issue solved,Click Kudos & Accept as Solution

Re: Magento 2.1.10 to 2.2.5 nothing happened

Hi @ManthanDave

 

Yes, I tried what you mentioned above but things did not change.

But I tried again and after this command a got this error.

php bin/magento setup:di:compile

"MIBPHP: fatal error: allowed memory size of 134217728 bytes exhausted (try to allocated 32768 bytes) in xy.hu/public_html/app/code/Magento/Search/Block/Adminhtml/Dashboard/Top.php on line 1

 

and after this command:

php bin/magento setup:static-content:deploy

.PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 1048576 bytes) in /xy.hu/public_html/lib/internal/Magento/Framework/View/Asset/Bundle.php on line 192

Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors for more info on how to handle out of memory errors.admin@dev:~/web/xy.hu/public_html$

Re: Magento 2.1.10 to 2.2.5 nothing happened

Hi @tomzol

 

Its memory limit error , you need to increase your memory_limit parameter from php.ini file

 

increase your memory_limit parameter in php.ini at least 2048M

 

Also increase max_execution_time to 18000

 

Then check it will works !

if issue solved,Click Kudos & Accept as Solution

Re: Magento 2.1.10 to 2.2.5 nothing happened

Hi @ManthanDave

 

Thank you for your help.

I got this answer every time when I run the composer update.

"Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package magento/product-community-edition could not be found in any version, there may be a typo in the package name.

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details."