cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.1.6 Upgrade to 2.2.2 EE

Magento 2.1.6 Upgrade to 2.2.2 EE

I want to upgrade the Magento EE 2.1.6 version via composer

 

Comper.json

 

 

{
    "name": "magento/project-enterprise-edition",
    "description": "eCommerce Platform for Growth (Enterprise Edition)",
    "type": "project",
    "version": "2.1.6",
    "license": [
        "proprietary"
    ],
    "repositories": [
        {
            "type": "composer",
            "url": "https://repo.magento.com/"
        }
    ],
    "require": {
        "magento/product-enterprise-edition": "2.2.2",
        "composer/composer": "@alpha"
        
    },
    "require-dev": {
        "phpunit/phpunit": "4.1.0",
        "squizlabs/php_codesniffer": "1.5.3",
        "phpmd/phpmd": "2.3.*",
        "pdepend/pdepend": "2.2.2",
        "sjparkinson/static-review": "~4.1",
        "fabpot/php-cs-fixer": "~1.2",
        "lusitanian/oauth": "~0.3 <=0.7.0"
    },
    "config": {
        "use-include-path": true
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": "app/code/"
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/",
            "Magento\\ToolkitFramework\\": "dev/tools/performance-toolkit/framework/Magento/ToolkitFramework/"
        }
    },
    "minimum-stability": "alpha",
    "prefer-stable": true,
    "extra": {
        "magento-force": "override"
    }
}

Error while running the command composer update

$ composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package magento/product-enterprise-edition 2.2.2 exists as magento/product-enterprise-edition[2.1.6] but these are rejected by your constraint.

Kindly provide a solution.

 

Tags (1)
3 REPLIES

Re: Magento 2.1.6 Upgrade to 2.2.2 EE

There are instructions on how to upgrade using the command line here: http://devdocs.magento.com/guides/v2.1/comp-mgr/cli/cli-upgrade.html

 

How did you originally install Magento? 

 

I think it might be because you have this line in your composer.json file:

 

    "version": "2.1.6",

 

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: Magento 2.1.6 Upgrade to 2.2.2 EE

@Tom Robertshaw I am getting the same error even if I update the composer.json

 "version": "2.1.6"

 

$ composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)

Spoiler

Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package magento/product-enterprise-edition 2.2.2 exists as magento/product-enterprise-edition[2.1.6] but these are rejected by your constraint.

 

 

Re: Magento 2.1.6 Upgrade to 2.2.2 EE

Did you remove that version line?
----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!