cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 2.4.2 to 2.4.3 failed

Magento 2.4.2 to 2.4.3 failed

Hi,

I tried to upgrade Magento from 2.4.2 to 2.4.3, but I get some error messages.

 

How can I resolve this? The messages are:

 

Problem 1

    - Root composer.json requires magento/product-community-edition 2.4.3 -> satisfiable by magento/product-community-edition[2.4.3].

    - klarna/module-core 6.2.2 requires guzzlehttp/guzzle ^6.3.3 -> satisfiable by guzzlehttp/guzzle[6.3.3, ..., 6.5.5].

    - You can only install one version of a package, so only one of these can be installed: guzzlehttp/guzzle[v1.0.3, v1.0.4, v2.0.0, ..., v2.8.8, v3.0.0, ..., v3.8.1, 4.0.0, ..., 4.2.4, 5.0.0, ..., 5.3.4, 6.0.0, ..., 6.5.5, 7.0.0, ..., 7.3.0].

    - klarna/m2-payments 8.3.2 requires klarna/module-core 6.2.2 -> satisfiable by klarna/module-core[6.2.2].

    - magento/magento2-functional-testing-framework 3.7.0 requires guzzlehttp/guzzle ^7.3.0 -> satisfiable by guzzlehttp/guzzle[7.3.0].

    - magento/product-community-edition 2.4.3 requires klarna/m2-payments 8.3.2 -> satisfiable by klarna/m2-payments[8.3.2].

    - Root composer.json requires magento/magento2-functional-testing-framework ^3.7.0 -> satisfiable by magento/magento2-functional-testing-framework[3.7.0].

 

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

5 REPLIES 5

Re: Magento 2.4.2 to 2.4.3 failed

Did you find any solution?

Re: Magento 2.4.2 to 2.4.3 failed

Unfortunately not.

Re: Magento 2.4.2 to 2.4.3 failed

Hello @alexander_jorda 

 

There are two ways :
1. first way one by one module update using composer
2. compare latest Magento composer.json after change required

 

After run again composer update command and check.

 

Hope it will work for you! 

Was my answer helpful? You can accept it as a solution.
150+ professional extensions for M1 & M2 with free lifetime updates!

Re: Magento 2.4.2 to 2.4.3 failed

It still has not been solved yet. But I do get another error this time. 

 

 Problem 1

    - Root composer.json requires magento/product-community-edition 2.4.3 -> satisfiable by magento/product-community-edition[2.4.3].

    - Root composer.json requires magento/magento2-functional-testing-framework ^3.7.0 -> satisfiable by magento/magento2-functional-testing-framework[3.7.0].

    - magento/magento2-functional-testing-framework 3.7.0 requires guzzlehttp/guzzle ^7.3.0 -> satisfiable by guzzlehttp/guzzle[7.3.0, 7.4.0].

    - You can only install one version of a package, so only one of these can be installed: guzzlehttp/guzzle[v1.0.3, v1.0.4, v2.0.0, ..., v2.8.8, v3.0.0, ..., v3.8.1, 4.0.0, ..., 4.2.4, 5.0.0, ..., 5.3.4, 6.0.0, ..., 6.5.5, 7.0.0, ..., 7.4.0].

    - Conclusion: install guzzlehttp/guzzle 6.5.3 (conflict analysis result)

 

Why is it saying that it requires Magento 2.4.3 and Magento 2.4.3 is satisfiable? Also for the testing framework is it saying that. I do not understand this error, because in my composer.json I have Magento 2.4.3 and functional testing framework 3.7.0. 

Re: Magento 2.4.2 to 2.4.3 failed

Hi @alexander_jorda

There are two different ways :

1. first way individually module update utilizing arranger

2. analyze most recent Magento composer.json after change required

After run again arranger update order and check.

Expectation it will work for you!

Was my answer accommodating? You can acknowledge it as an answer.

150+ expert expansions for M1 and M2 with free lifetime refreshes!