cancel
Showing results for 
Search instead for 
Did you mean: 

Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

SOLVED
Highlighted

Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

Hello all, 

 

on trying to upgrade from magento 2.2.6 to 2.3 (CE) I get the following error - does anybody know how to get this fixed? Btw - I do not want to develop stuff for my magento application. 

 

Check Component Dependency

We found conflicting component dependencies. Hide detail

Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- magento/magento-coding-standard 1.0.2 requires squizlabs/php_codesniffer ~3.3.0 -> satisfiable by squizlabs/php_codesniffer[3.3.0, 3.3.1, 3.3.2] but these conflict with your requirements or minimum-stability.
- magento/magento-coding-standard 1.0.1 requires squizlabs/php_codesniffer ~3.3.0 -> satisfiable by squizlabs/php_codesniffer[3.3.0, 3.3.1, 3.3.2] but these conflict with your requirements or minimum-stability.
- magento/magento-coding-standard 1.0.0 requires squizlabs/php_codesniffer ~3.3.0 -> satisfiable by squizlabs/php_codesniffer[3.3.0, 3.3.1, 3.3.2] but these conflict with your requirements or minimum-stability.
- Installation request for magento/magento-coding-standard ~1.0.0 -> satisfiable by magento/magento-coding-standard[1.0.0, 1.0.1, 1.0.2].

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

Hello @fabianus ,

It seems that the issue is because of squizlabs/php_codesniffer version. You still have older version of squizlabs/php_codesniffer which is not supported by magento/magento-coding-standard 1.0.2

In your magento root's directory, please take the backup of old composer.json and in new composer.json just edit the version of squizlabs/php_codesniffer like

"squizlabs/php_codesniffer": "3.3.1"

Save the composer.json and execute the update command again. Hope this will solves your issue.

If it helps you, please give us kudos and accept it as solution.

Thank you

View solution in original post

6 REPLIES 6
Highlighted

Re: Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

Hi @fabianus,

Which method you are trying to upgrade?

I will suggest to upgrade using composer.

You can upgrade using following method:

Take a full backup of code and database before upgrade.

Try once the following commands in the sequence,

rm -rf var/cache/* var/page_cache/* var/generation/*
sudo chmod -R 0777 var/ pub/ generated/
php bin/magento deploy:mode:set developer
php bin/magento cache:disable
php bin/magento maintenance:enable
composer require magento/product-community-edition 2.3.2 --no-update
composer update
rm -rf var/cache/* var/page_cache/* var/generation/*
sudo chmod -R 0777 var/ pub/ generated/
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento cache:enable
php bin/magento maintenance:disable
php bin/magento indexer:reindex && php bin/magento cache:clean && php bin/magento cache:flush

I Hope it will help you!
----
Problem solved? Click Accept as Solution!
Highlighted

Re: Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

Hello @fabianus ,

It seems that the issue is because of squizlabs/php_codesniffer version. You still have older version of squizlabs/php_codesniffer which is not supported by magento/magento-coding-standard 1.0.2

In your magento root's directory, please take the backup of old composer.json and in new composer.json just edit the version of squizlabs/php_codesniffer like

"squizlabs/php_codesniffer": "3.3.1"

Save the composer.json and execute the update command again. Hope this will solves your issue.

If it helps you, please give us kudos and accept it as solution.

Thank you

View solution in original post

Highlighted

Re: Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

If you want to upgrade it again by following all the steps (I think you have already followed them) you can use the link https://community.magento.com/t5/Installing-Magento-2-x/Upgrade-from-2-1-7-to-2-3-2/m-p/139371/highl...

In the above link (Step 5), it has already used the 3.3.1 versionsquizlabs/php_codesniffer version.

Hope it will help you.

Highlighted

Re: Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

thanks sarvagya - that's how I proceeded !

Highlighted

Re: Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

You are welcome @fabianus .

If you like my answer please give kudos to the solution.

Thank you Smiley Happy

Highlighted

Re: Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

Hi Sarvagya, my post wasn't clear: I wanted to say that this is the way I proceeded, but yet I have the stated error message ...