cancel
Showing results for 
Search instead for 
Did you mean: 

Migration 1.8.1 to 2.2.4 ; downloading migration tool -> composer.json not found

Migration 1.8.1 to 2.2.4 ; downloading migration tool -> composer.json not found

[~/public_html/store224]# composer config repositories.magento composer https://repo.magento.com
X-Powered-By: PHP/5.6.36
Content-type: text/html; charset=UTF-8

Warning: Composer should be invoked via the CLI version of PHP, not the cgi-fcgi SAPI

                                                                 
  [RuntimeException]                                             
  File "composer.json" cannot be found in the current directory  
                                                                 

config [-g|--global] [-e|--editor] [-a|--auth] [--unset] [-l|--list] [-f|--file FILE] [--absolute] [--] [<setting-key>] [<setting-value>]...

Trying to download the migration tool and the above is the exception that I am receiving.

 

Assistance is much appreciated.

4 REPLIES

Re: Migration 1.8.1 to 2.2.4 ; downloading migration tool -> composer.json not found

Hi @Texasbull

 

have you try another option - to install this migration tool via github ?

 

composer config repositories.data-migration-tool git https://github.com/magento/data-migration-tool

composer require magento/data-migration-tool:<version>

Refer this link for more details -  https://devdocs.magento.com/guides/v2.0/migration/migration-tool-install.html

if issue solved,Click Kudos & Accept as Solution

Re: Migration 1.8.1 to 2.2.4 ; downloading migration tool -> composer.json not found


@ManthanDave wrote:

Hi @Texasbull

 

have you try another option - to install this migration tool via github ?

 

composer config repositories.data-migration-tool git https://github.com/magento/data-migration-tool

composer require magento/data-migration-tool:<version>

Refer this link for more details -  https://devdocs.magento.com/guides/v2.0/migration/migration-tool-install.html


Same error, unfortunately. is there a special way that I need to call the function I have tried with php and with php-cli. the exception is directly as you have it.

 

Further, I can see that composer.json is in the current directory, I am not sure why it is stating the contrary!

Re: Migration 1.8.1 to 2.2.4 ; downloading migration tool -> composer.json not found

You need to install first composer in your system,

run below command from magento root,

composer install
If Issue Solved, Click Kudos/Accept As solutions.

Re: Migration 1.8.1 to 2.2.4 ; downloading migration tool -> composer.json not found

I have multiple php versions on my server for different domains. I have the project domain set to php 7.1 but it keeps picking up the 5.6.36 that is active on the other domains.

 

[~/public_html/store224]# php-cli /usr/local/bin/composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (5.6.36) does not satisfy that requirement.
    - magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (5.6.36) does not satisfy that requirement.
    - Installation request for magento/framework 101.0.4 -> satisfiable by magento/framework[101.0.4].

@Rakesh Jesadiya wrote:

You need to install first composer in your system,

run below command from magento root,

composer install