cancel
Showing results for 
Search instead for 
Did you mean: 

Problems Upgrading from 2.1.3 to 2.1.5 (Urgent)

Problems Upgrading from 2.1.3 to 2.1.5 (Urgent)

Hello,

 

I'm trying to upgrade magento from 2.1.3 to 2.1.5 through the backend, but I'm getting this "You're already using the latest version, there's nothing for us to do."

 

I even tried to do that using Composer, but yet getting another problem "The requested package magento/product-community-edition 2.1.5 exists as magento/product-community-edition[2.1.3] but these are rejected by your constraint."

 

And when i went to components manager i got the following error after debugging it "GET componentGrid/components 500 (Internal Server Error)" I went to that path to check what's going on, and i found this:

 

I really need help to get this issues solved ASAP, i believe by upgrading the platform all of these problems should be solved automatically.

2 REPLIES

Re: Problems Upgrading from 2.1.3 to 2.1.5 (Urgent)

@Zerocard

 

Try doing the following: 

 

  • Remove cache, di, view_preprocessed and page_cache directories
  • Make sure that 2.1.5 is set as the Magento version in your composer.json file
  • Re-run composer
  • Run system upgrade
  • Run system compile
  • Deploy static content 

I hope this will fix the issue. If not then it's best to check the system.log file for any possible issues. 

 

 

 

 

Magento Certified Solution Specialist | Lead Magento developer
If this response was helpful to you, consider giving kudos to this post

Re: Problems Upgrading from 2.1.3 to 2.1.5 (Urgent)

I got this when i did do the following:

composer require magento/product-community-edition 2.1.5

 

  Problem 1
    - Installation request for colinmollenhour/php-redis-session-abstract (locked at v1.1) -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.1].
    - magento/product-community-edition 2.1.5 requires colinmollenhour/php-redis-session-abstract 1.2 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.2].
    - magento/product-community-edition 2.1.5 requires colinmollenhour/php-redis-session-abstract 1.2 -> satisfiable by colinmollenhour/php-redis-session-abstract[v1.2].
    - Conclusion: don't install colinmollenhour/php-redis-session-abstract v1.2
    - Installation request for magento/product-community-edition 2.1.5 -> satisfiable by magento/product-community-edition[2.1.5].